[openstack-dev] Getting GERRIT error while submitting spec for liberty.

Claudio Pupparo claudio.pupparo at gmail.com
Sat Apr 4 12:05:05 UTC 2015

Ok, I've read your answer to Vikram and I'm in the first case, where
"gerrit version" works but "git review -s" doesn't.
I thought by adding manually the remote I have solved the problem.

I'll check the step in the documentation again, thank you Jeremy.


Il 04-Apr-15 1:50 PM, Jeremy Stanley ha scritto:
> On 2015-04-04 13:38:07 +0200 (+0200), Claudio Pupparo wrote:
>> I had the same problem. I had first to manually add the remote:
>> git remote add gerrit
>> ssh://vikram.choudhary@review.openstack.org:29418/openstack/neutron-specs.git
>> then "git review -s" worked.
> You misunderstand. That remote is what git review -s wants to add on
> its own. If you manually added the remote yourself, then rerunning
> git review -s is pointless as that command simply sees the remote it
> wanted to add is already there and does nothing instead. Further
> testing is required to find out _why_ git review -s fails its test
> push when trying to add that remote on its own.
> The answer to these sorts of questions is to _first_ point people
> back at the documentation, because this problem almost always means
> an account setup step was missed or performed incorrectly.

More information about the OpenStack-dev mailing list