[openstack-dev] [requirements] - taskflow preventing sqla 0.8 upgrade

Clint Byrum clint at fewbar.com
Sun Jan 5 16:18:55 UTC 2014

I've skimmed the rest of the thread and not seen something mentioned
that seems like it matters a lot. If I missed this suggestion buried
deep in the ensuing discussion, I apologize for that.

Since TaskFlow wants to be generally consumable and not only driven as
an OpenStack component, it should not be following global requirements.
It should actually expand its SQL Alchemy compatibility to all supported
versions of SQLAlchemy. Ideally it would have a gate for each major
version of SQL Alchemy that upstream supports.

Otherwise it will never even be able to work with any project that
doesn't share its SQL Alchemy version pin.

Excerpts from Joshua Harlow's message of 2014-01-03 08:37:17 -0800:
> So taskflow was tested with the version of sqlalchemy that was available and in the requirements at the time of its 0.1 release (taskflow syncs it's requirements from the same global requirements). From what I remember this is the same requirement that everyone else is bound to:
> SQLAlchemy>=0.7.8,<=0.7.99
> I can unpin it if this is desired (the openstack requirements repo has the same version restriction). What would be recommended here? As more code moves to pypi reusable libraries (oslo.db when it arrives comes to mind) I think this will be hit more often. Let's come up with a good strategy to follow.
> Thoughts??

More information about the OpenStack-dev mailing list