[openstack-dev] [XenAPI] One issue on xenapi environment setup

John Garbutt John.Garbutt at citrix.com
Wed Jan 23 15:08:45 UTC 2013

> Thanks for all your great help, my xen environment is up in VirtualBox. I can
> even fetch the rrd_updates now :)
Thank you for your help and persistence!

> So to devstack/xenapi in virtualbox, I noticed several thing that can be
> enhanced:
> a) If try several ./install_os_domU.sh several times, it will unzip multiple nova
> directory under tools/xen/nova/, and cause issue, I have created a patch for
> it, https://review.openstack.org/#/c/20303/
Oops. Thanks. I guess our Jenkins scripts "fix" that one.

> (BTW, what's the "master" in
> the install_os_domU.sh script? I didn't find anyone create that file/directory.
I think that comes from the branch name, which dictates the URL of the zip file downloaded.
It used to be hard coded to master, but got updated to support stable/*

> 2) In my environment, I have proxy setting. However, currently xenapi in
> devstack does not considering such situation. At least I need two changes,
> one is the install-proxy for the template, another one is the mirror proxy in
> devstackubuntupreseed.cfg. With these changes, at least the
> DevstackOSDOMU will be up.
Yes, it would be nice to add these. Not tried a setup in the presence of a proxy.

> 3) The DevstackOSDomU should have proxy also, so that the ./stack.sh can
> work well. However, I think this is a bit tricky, and I have no idea how can do
> this automatically, especially we need make sure the communication with
> dom0 will not be proxied.
I think you can setup a proxy ignore list:
It's a hack, but you could write the appropriate config file at this point:

> 4) the XenAPI package will not be installed by devstack, and n-cpu service will
> fail.  The reason is because the XenAPI is not in the pip-requires. (one minor
> thing is, because xenapi package has same name as nova/virt/xenapi, the
> exception information is a bit confusing when import XenAPI failed).
I think this will be fixed by (3). I guess the following line (silently!) fails due to your proxy issues:

> 5) The wiki for the xenserver in virtualBox need be updated that the
> Promiscuous mode should be enabled.
Thanks, I somehow missed out that bit! I have added that to the wiki.
> Also, we can tell the user that Ubuntu
> 12.04 has virtualBox support already. (I tried to install latest dpkg from
> virtualbox website, and then have to find method to purge it. IMHO, apt-get
> is the easiest method in Ubuntu)
Thanks, added something that should help. I was testing on Windows.
> I'm not what should be fixed. Possibly I can work on item 2) later when I have
> bandwidth, but I have no idea of solution to 3/4.
I would certainly welcome your patches :-)
I hope the suggestions above might help anyone who gets chance to take a look.
> Again, thanks for your great help on this.
Thank you! Sorry there was so much pain getting it all working!


More information about the OpenStack-dev mailing list