[Openstack] Keystone response dead slow with gateway time out

Bhujay Bhatta bhujay.bhatta at hotmail.com
Wed May 17 10:00:25 UTC 2017

I am running curl command on the keystone container itself and the result is coming after 40s .  If I try with any other user it shows gateway time out .  I  have deployed openstack using openstack ansible ( tried newton and ocata )  following their reference architecture for production . It worked file for some time and then the gateway time out syndrome started coming out intermittently . After a restart of the controller  all commands are giving gateway time out.  Suspecting HAproxy i have increased time out value and finally ran the API inside the keystone container itself .  Any suggestion is appreciated  .

In keystone container’s apache-error.log has  this error , all other logs are normal

2017-05-17 15:18:37.910591 Timeout when reading response headers from daemon process 'keystone-admin': /var/www/cgi-bin/keystone/admin
2017-05-17 15:19:07.406267 mod_wsgi (pid=3139): Exception occurred processing WSGI script '/var/www/cgi-bin/keystone/admin'.
2017-05-17 15:19:07.406433 IOError: failed to write data


Warm Regards, Bhujay

I tried this command .

time curl -i -g --insecure \
  -H "Content-Type: application/json" \
  -d '
{ "auth": {
    "identity": {
      "methods": ["password"],
      "password": {
        "user": {
          "name": "admin",
          "domain": { "id": "default" },
          "password": "welcome at 123"
}' \
  http://localhost:5000/v3/auth/tokens ; echo

Warm Regards, Bhujay

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstack.org/pipermail/openstack/attachments/20170517/2587f5bf/attachment.html>

More information about the Openstack mailing list