[Openstack] Unable to deploy OS - network issues

Mio Vlahović Mio.Vlahovic at bcs.hr
Thu May 11 13:08:29 UTC 2017

Hello openstackers,

We have tried to deploy testing environment for openstack, but failed 
couple of times with the same problem.

We tried using fuel version 11 and 12-nightly, and also mirantis distro 
but without success. I can see that I'm failing somewhere in the 
configuration but cannot grasp what the issue is.

So, after deploying master node, we PXE booted 3 slave nodes (1 
controller, 1 compute and 1 cinder node), added roles and configured 
For the network, we are using 2 interfaces on each node. One is for PXE 
network and the other is trunk of several vlans (management, tenant, 
storage and public). So, all traffic is tagged.

After verifying network connectivity (which passes successfully), we hit 
deploy button and wait for it to finish. At the end, we get this error: 
Deployment has failed. All nodes are finished. Failed tasks: 
Task[connectivity_tests/1], Task[connectivity_tests/3] Stopping the 
deployment process!

After SSHing to controller node, to test the network connectivity with 
other nodes and the internet, all is fine. But on the cinder and compute 
node we can't reach the management gateway (but all other IPs in the 
subnets are reachable), and hence, we can't reach the internet so the 
deployment fails with
ERROR: Unable to fetch url 
'http://mirror.fuel-infra.org/mos-repos/ubuntu/9.0/', error 'No route to 
host - connect(2)'. Please verify node connectivity to this URL, or 
remove it from the settings page if it is invalid. on node node-1.lab.corp

Can anyone point me in the direction where to look for the possible 
solutions? If you need any logs from the nodes or any other info just 
tell me and I will put them on some pastebin site.


Mio Vlahović
Linux/Network Administrator @ BCS d.o.o.
GSM: +385 95 6308 809

More information about the Openstack mailing list