[Openstack] Unit Test Error when test servers.py using tox

Jeremy Stanley fungi at yuggoth.org
Mon Mar 27 14:51:19 UTC 2017

On 2017-03-24 02:55:39 +0000 (+0000), Pei Pei2 Jia wrote:
> I'm a freshman in openstack. I want to contribute and learn some
> exciting by joining openstack. I will be grateful if anyone can
> help me on my starting process.

You're likely to want to use the openstack-dev at lists.openstack.org
mailing list for development-related topics, since a lot more of the
developer community subscribes to and watches that.

> Now I encounter a problem when I tried the UT with tox.
> I execute the following command,
> (.venv-nova)[jiapei2 at localhost nova]$ tox -e py27 tests.unit.api.openstack.compute.test_server_action
> And then I got the results:
> =====
> Totals
> ======
> Ran: 136 tests in 51.0000 sec.

I'm not an active developer on nova, but I tried to recreate the
issue you encountered out of personal curiosity. Unfortunately I
don't have a good explanation for it. At least on my workstation
(Debian/unstable) with tox 2.5.0 installed from PyPI and a clean
checkout of nova's master branch, rerunning `tox -e py27
tests.unit.api.openstack.compute.test_server_action` results in:

    Ran: 66 tests in 41.0000 sec.
     - Passed: 66
     - Skipped: 0
     - Expected Fail: 0
     - Unexpected Success: 0
     - Failed: 0
    Sum of execute time for each test: 51.4564 sec.

Worth noting, `tox -e bindep` says I'm missing several system
packages (graphviz, libsqlite3-dev, mysql-client, mysql-server,
postgresql, postgresql-client) which I guess might explain why I
only ran 66 tests instead of 136, though the failures you quoted
didn't look like they were related to any tests which would have
needed those.
Jeremy Stanley

More information about the Openstack mailing list