[Openstack] communication between two VMs

Neil Jerram neil at tigera.io
Tue Mar 14 11:11:08 UTC 2017

Hi David,

The interface name "eth1" implies - or at least strongly suggests - that
each of your VMs has two interfaces (eth0 and eth1).  Is that the case?

It's also a bit odd that you have to do 'ifconfig eth1 up' by hand.
Normally the VM OS should do that; and if it isn't, there are probably
other things that aren't happening for eth1, such as DHCP and setting up
the routing table for it.

Could you do what you're trying to do first with just one VM interface,
eth0, which OpenStack should fully set up for you?


On Tue, Mar 14, 2017 at 10:51 AM David Gabriel <davidgab283 at gmail.com>

> Dears,
> I have defined this simple topology:
>                     Internet ----- VM1 ----LAN---- VM2 -----Internet
> I made 'ifconfig eth1 up' for each VM to activate the interface.
> Then I tried to make the ping between the two VMs but it fails !
> So I run the bellow command in one VM and re-run the ping in the other one
> tcpdump -i eth1 icmp and icmp[icmptype]=icmp-echo
> But I did not receive any packet despite that ICMP packets are allowed in
> both directions (IN/OUT) !
> Could you please tell me how to fix this problem.
> Thanks in advance.
> Regards
> _______________________________________________
> Mailing list:
> http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack
> Post to     : openstack at lists.openstack.org
> Unsubscribe :
> http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstack.org/pipermail/openstack/attachments/20170314/1de29a4f/attachment.html>

More information about the Openstack mailing list