[Openstack] Issue installing OpenStack Pike with Devstack

d.lake at surrey.ac.uk d.lake at surrey.ac.uk
Thu Dec 7 07:49:38 UTC 2017

Hi Bernd

Thanks - I’ll start looking around at glance and Apache.   I’ve told Devstack not to load the sample images and it is now failing further along with a 500 Error so it is certainly something around HTTP.

This is SO annoying because all I am trying to do is to take a working system and clone it into identical hardware.   I’m not changing any versions or even any of the layout.

Even if I clone the /opt/stack/Devstack directory, the first thing that stack seems to do is connect out and pull down not the versions of underlying code which worked before but the latest.   Even the “upper-requirements” file is pulled down so I can’t nail that down to what I know works.

I’m going to clean everything out on the new system and just run the most simple Devstack to see if that works.


Sent from my iPhone
From: Bernd Bausch <berndbausch at gmail.com>
Sent: Thursday, December 7, 2017 7:01:33 AM
To: Lake D Mr (PG/R - Elec Electronic Eng); Openstack at lists.openstack.org
Subject: RE: [Openstack] Issue installing OpenStack Pike with Devstack

> The proxy server received an invalid: response from an upstream server.
(HTTP 502)

Apache is the proxy server for Glance in this case. The message says that
Apache doesn't get the expected response from Glance, which could mean that
Glance is not running at all. Check for other errors further up in the log.

An earlier local.conf not working anymore on a newer DevStack version has
hit me as well at times. You may have to carefully evaluate what you need in
your cloud and throw out everything else. You might also have version
mismatches - remember that enable_plugin has an optional version parameter.

Bernd Bausch

From: d.lake at surrey.ac.uk [mailto:d.lake at surrey.ac.uk]
Sent: Thursday, December 7, 2017 8:45 AM
To: Openstack at lists.openstack.org
Subject: Re: [Openstack] Issue installing OpenStack Pike with Devstack

Following from my earlier email, I’ve traced the problem to a mis-match of
arguments between /opt/stack/nova/nova/db/sqlalchemy/api.py and nova-manage.

If I change api.py to exclude the retry_on_request from the list of
arguments, nova-manage works.

This is obviously the wrong thing to do but at least it gets things

At least, I get further through the installation.

I am now seeing another error further down the installation:

2017-12-06 23:36:40.076 | + functions:upload_image:380               :
openstack --os-cloud=devstack-admin --os-region-name=RegionOne image create
cirros-0.3.5-x86_64-disk --public --container-format=bare --disk-format
2017-12-06 23:36:42.338 | 502 Bad Gateway: Bad Gateway: The proxy server
received an invalid: response from an upstream server. (HTTP 502)

I’m not using a proxy server so I have no idea where THIS one is coming
from.  If I run the command manually, it works.


From: Lake D Mr (PG/R - Elec Electronic Eng)
Sent: 06 December 2017 21:49
To: 'Openstack at lists.openstack.org' <Openstack at lists.openstack.org>
Subject: Issue installing OpenStack Pike with Devstack


I’m trying to install a new OpenStack Pike environment using Devstack.  The
local.conf is identical to a system built in early October (same base OS –
CentOS7, same interfaces, different IP addresses, but that is all).

The system in October installed perfectly.

This system refuses to install falling over at the very first “nova-manage”

2017-12-06 21:36:36.337 | + lib/nova:init_nova:694                   :
/usr/bin/nova-manage --config-file /etc/nova/nova.conf api_db sync
2017-12-06 21:36:38.426 | Traceback (most recent call last):
2017-12-06 21:36:38.426 |   File "/usr/bin/nova-manage", line 6, in <module>
2017-12-06 21:36:38.427 |     from nova.cmd.manage import main
2017-12-06 21:36:38.427 |   File "/opt/stack/nova/nova/cmd/manage.py", line
82, in <module>
2017-12-06 21:36:38.427 |     from nova import config
2017-12-06 21:36:38.427 |   File "/opt/stack/nova/nova/config.py", line 23,
in <module>
2017-12-06 21:36:38.427 |     from nova.db.sqlalchemy import api as
2017-12-06 21:36:38.427 |   File
"/opt/stack/nova/nova/db/sqlalchemy/api.py", line 925, in <module>
2017-12-06 21:36:38.427 |     retry_on_request=True)
2017-12-06 21:36:38.427 | TypeError: __init__() got an unexpected keyword
argument 'retry_on_request'

The only difference I can see between the two systems is that the Python
libraries are different versions (oslo.db is 4.25.0 on the old system,
4.31.0 on the new one).

I have no idea where to start looking.



-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstack.org/pipermail/openstack/attachments/20171207/9097cb3f/attachment.html>

More information about the Openstack mailing list