[Openstack] heat CLI not working after modifying roles

Adam Young ayoung at redhat.com
Mon Aug 31 15:33:16 UTC 2015

On 08/27/2015 02:25 AM, kevin parrikar wrote:
> i have a user whose role was "_member_ "later changed to 
> "heat_stack_user" and again changed to "_member_" but now the user is 
> not able to do any heat commands as it returns
> "ERROR: You are not authorized to complete this action". for heat 
> stack-list and other heat commands but "nova list "is working fine
> I tried adding user to admin role
> keystone user-role-add --user=user10 --tenant=tenant9 --role=admin
> where "user10"  is member of 2-3 tenants:
> But its still the same even with admin role.So i suppose when i 
> changed the role something else  also changed which i am not able to 
> figure out.Can somebody help me in fixing this.
> _______________________________________________
> Mailing list: http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack
> Post to     : openstack at lists.openstack.org
> Unsubscribe : http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack

Did you change policy?

Use can have multiple roles, so admin, _member_ and heat_stack_user 
(while strange) could all be assigned to the same user.  You might need 
both depending on your setup.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstack.org/pipermail/openstack/attachments/20150831/7044ad31/attachment.html>

More information about the Openstack mailing list