[Openstack] Trove instance created with error status

Amrith Kumar amrith at tesora.com
Mon Oct 20 20:02:10 UTC 2014

Ali, that bug was fixed and the fix has been released. The symptoms appear similar though.


From: Ali Nazemian [mailto:alinazemian at gmail.com]
Sent: Monday, October 20, 2014 11:20 AM
To: Swapnil Kulkarni
Cc: Amrith Kumar; openstack
Subject: Re: [Openstack] Trove instance created with error status

Could it be related to this bug?

On Mon, Oct 20, 2014 at 12:26 PM, Swapnil Kulkarni <coolsvap at gmail.com<mailto:coolsvap at gmail.com>> wrote:
Hi Ali, Amrith,

I have been facing similar issue for some days now, I tried simple devstack, redstack for trove but the issue remains.
Today I tried it without neutron as well. But no success

Best Regards,
Swapnil Kulkarni
irc : coolsvap

On Sat, Oct 18, 2014 at 1:40 AM, Ali Nazemian <alinazemian at gmail.com<mailto:alinazemian at gmail.com>> wrote:
Dear Amrith,
Actually I did use "./stack.sh" command to install whole openstack package. I also did some tests on different module using exercise.sh script to check whether everything go fine. It seems that there is no problem with different openstack modules from the aspect of "exercise.sh". I also tried to check that nova can initiate instance or not. Everything was fine. I manage to see the instance console and it booted successfully. I also check the horizon when I tried to create trove instance. I found out that the nova instance corresponding to trove instance was created and booted successfully! FYI I did the process for mysql 5.5 and mongodb 2.4 both ended up to error state! Right now I am suspicious about neutron module. Could it be related to that?

On Fri, Oct 17, 2014 at 11:20 PM, Amrith Kumar <amrith at tesora.com<mailto:amrith at tesora.com>> wrote:
Ali, it appears that you may be using devstack. I’ve not seen this particular failure before but it could be one of several things.

What command(s) did you execute? I’m assuming that before trove create you did

devstack install
devstack kick-start <some db>

It would be good to know what database you chose.

Other things that’d be good to verify are that you are able to launch a nova instance (if Nova is no va then Trove will not work either).

Also, you’ll likely get quicker responses on IRC at #openstack-trove.

Hope that helps, thanks,



Amrith Kumar, CTO, Tesora

Twitter: @amrithkumar
Skype: amrith.skype
Web: http://www.tesora.com
IRC: amrith @freenode #openstack-trove #tesora

From: Ali Nazemian [mailto:alinazemian at gmail.com<mailto:alinazemian at gmail.com>]
Sent: Friday, October 17, 2014 2:46 PM
To: openstack
Subject: [Openstack] Trove instance created with error status

I install openstack icehouse with devstack script. I tried to create trove instance using "trove create" command. After passing around 10 min the status of created database becomes "error". I checked different logs i.e. screen-tr-api.log, screen-n-api.log screen-n-cpu.log nothing unusual detected. Only I found out that "screen-tr-api.log showed this error as a part of process:
2014-10-17 22:08:10.438 ERROR trove.guestagent.api [-] Error calling get_filesystem_stats
2014-10-17 22:08:10.438 TRACE trove.guestagent.api Traceback (most recent call last):
2014-10-17 22:08:10.438 TRACE trove.guestagent.api   File "/opt/stack/trove/trove/guestagent/api.py", line 53, in _call
2014-10-17 22:08:10.438 TRACE trove.guestagent.api     timeout=timeout_sec)
2014-10-17 22:08:10.438 TRACE trove.guestagent.api   File "/opt/stack/trove/trove/openstack/common/rpc/proxy.py", line 130, in call
2014-10-17 22:08:10.438 TRACE trove.guestagent.api     exc.info<http://exc.info>, real_topic, msg.get('method'))
2014-10-17 22:08:10.438 TRACE trove.guestagent.api Timeout: Timeout while waiting on RPC response - topic: "guestagent.9f153047-baf1-494a-b369-bad88582afe4", RPC method: "get_filesystem_stats" info: "<unknown>"
2014-10-17 22:08:10.438 TRACE trove.guestagent.api
2014-10-17 22:08:10.438 ERROR trove.instance.models [-] An error occurred communicating with the guest: Timeout while waiting on RPC response - topic: "guestagent.9f153047-baf1-494a-b369-bad88582afe4", RPC method: "get_filesystem_stats" info: "<unknown>".

Would you please help me to find out what is the source of this problem and how can I fix that?
Best regards.



Mailing list: http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack
Post to     : openstack at lists.openstack.org<mailto:openstack at lists.openstack.org>
Unsubscribe : http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstack.org/pipermail/openstack/attachments/20141020/c0cece88/attachment.html>

More information about the Openstack mailing list