[Openstack] Question about debugging nova-network with single host network/ flatdhcpmanager

Zhi-Wei Lu zwlu at ucdavis.edu
Mon May 26 21:54:31 UTC 2014

Hi all,

I have been experimenting with openstack for a while (on and off) using 
a few different network options, I have tried neutron network, 
nova-network multi_host, and nova-network with a single network host.

I have tried to run the nova-network (single network host) on one of the 
compute nodes, it worked somewhat. I finally tried to make the 
controller as the single nova-network host, but I encountered more 
issues than when I was running the nova-network on a compute node. I 
referenced one of the nice articles from


The controller is running CentOS 6.5.  When I started the nova-network, 
the network script would apply iptables rules for, but 
it didn't even tried to configure br100, and starting dnsmasq, the 
network initialization side step a few tasks. I ran the nova-network 
with --debug flag, I didn't see those initialization steps being started 
at all.  I would like to hear some debugging tips to track down the root 
of the problem.

The controller has been an experimental server for a few other projects, 
therefore, some of the system settings might prevent nova-network from 
start some of the initialization process.  I would like to get to the 
bottom of the issue, I could post more configuration settings if 
needed.  During my experimentation, I have encountered with a numbers of 
problems for which I were able to find answers online, debugging the 
openstack issue helped my understanding of openstack much better, thus 
help resolving problem quickly once we start a real production openstack 

Thank you.

Zhi-Wei Lu
IET-CR-Network Operations Center
University of California, Davis
(530) 752-0155

More information about the Openstack mailing list