[Openstack] Network problem in instances created in compute node

t22330033 t22330033 at gmail.com
Thu May 15 09:41:36 UTC 2014

I'm using devsatck on one controller node and one compute node. the
instance created in controller node can get IP address by DHCP without
problem but those in compute node always fail to get IP address. I tried to
trace the DHCP request and found it was not forwarded out of the compute
node. I think the problem could be the ovs settings but I don't know how to
solve it. here is what did to trace the problem

1. ovs-vsctl show
    Manager "tcp:"
        is_connected: true
    Bridge br-int
        Controller "tcp:"
            is_connected: true
        fail_mode: secure
        Port "tap766671cd-d8"
            tag: 1
            Interface "tap766671cd-d8"
        Port br-int
            Interface br-int
                type: internal
        Port patch-tun
            Interface patch-tun
                type: patch
                options: {peer=patch-int}
        Port "vxlan-"
            Interface "vxlan-"
                type: vxlan
                options: {key=flow, local_ip="",
    Bridge br-tun
        Port patch-int
            Interface patch-int
                type: patch
                options: {peer=patch-tun}
        Port "vxlan-ac1f007d"
            Interface "vxlan-ac1f007d"
                type: vxlan
                options: {in_key=flow, local_ip="",
out_key=flow, remote_ip=""}
        Port br-tun
            Interface br-tun
                type: internal
    ovs_version: "2.1.90"

2. capture packets of DHCP request in all ports of the two bridges. I found
the packet went through tap766671cd-d8 and
vxlan- in br-int but not patch-tun. according to
it should go to patch-tun and then patch-int in br-tun. obviously it does
3. I tried to dump the flows of ovs and it seems the packet won't go
through br-tun with the flow setting. is this the root cause? if so, how do
I modify the flow setting by changing local.conf for stack.sh?
$ ovs-ofctl dump-flows br-int -O OpenFlow13
OFPST_FLOW reply (OF1.3) (xid=0x2):
 cookie=0x0, duration=2294.917s, table=0, n_packets=9, n_bytes=1434,
send_flow_rem in_port=2,dl_src=fa:16:3e:d6:ee:31
 cookie=0x0, duration=2285.698s, table=0, n_packets=0, n_bytes=0,
send_flow_rem priority=8192,in_port=2 actions=drop
 cookie=0x0, duration=2264.881s, table=0, n_packets=0, n_bytes=0,
send_flow_rem tun_id=0x3e9,in_port=3 actions=goto_table:20
 cookie=0x0, duration=3133.421s, table=0, n_packets=0, n_bytes=0,
send_flow_rem dl_type=0x88cc actions=CONTROLLER:56
 cookie=0x0, duration=2272.421s, table=10, n_packets=5, n_bytes=650,
send_flow_rem priority=8192,tun_id=0x3e9 actions=goto_table:20
 cookie=0x0, duration=2262.715s, table=10, n_packets=4, n_bytes=784,
 cookie=0x0, duration=2267.424s, table=20, n_packets=0, n_bytes=0,
send_flow_rem priority=8192,tun_id=0x3e9 actions=drop
 cookie=0x0, duration=2281.314s, table=20, n_packets=0, n_bytes=0,
send_flow_rem tun_id=0x3e9,dl_dst=fa:16:3e:d6:ee:31 actions=output:2
 cookie=0x0, duration=2275.604s, table=20, n_packets=9, n_bytes=1434,

# ovs-ofctl dump-flows br-tun
NXST_FLOW reply (xid=0x4):
 cookie=0x0, duration=3178.843s, table=0, n_packets=0, n_bytes=0,
idle_age=3178, priority=0 actions=drop
 cookie=0x0, duration=3179.361s, table=0, n_packets=631, n_bytes=57421,
idle_age=1, priority=1,in_port=1 actions=resubmit(,1)
 cookie=0x0, duration=3172.443s, table=0, n_packets=1270, n_bytes=92075,
idle_age=1, priority=1,in_port=2 actions=resubmit(,3)
 cookie=0x0, duration=3178.327s, table=1, n_packets=0, n_bytes=0,
idle_age=3178, priority=1,dl_dst=00:00:00:00:00:00/01:00:00:00:00:00
 cookie=0x0, duration=3177.807s, table=1, n_packets=631, n_bytes=57421,
idle_age=1, priority=1,dl_dst=01:00:00:00:00:00/01:00:00:00:00:00
 cookie=0x0, duration=3177.288s, table=2, n_packets=0, n_bytes=0,
idle_age=3177, priority=0 actions=drop
 cookie=0x0, duration=3176.746s, table=3, n_packets=1270, n_bytes=92075,
idle_age=1, priority=0 actions=drop
 cookie=0x0, duration=2343.819s, table=3, n_packets=0, n_bytes=0,
idle_age=2343, priority=1,tun_id=0x3e9 actions=mod_vlan_vid:1,resubmit(,10)
 cookie=0x0, duration=3176.235s, table=10, n_packets=0, n_bytes=0,
idle_age=3176, priority=1
 cookie=0x0, duration=3175.720s, table=20, n_packets=0, n_bytes=0,
idle_age=3175, priority=0 actions=resubmit(,21)
 cookie=0x0, duration=3175.199s, table=21, n_packets=631, n_bytes=57421,
idle_age=1, priority=0 actions=drop
 cookie=0x0, duration=2345.304s, table=21, n_packets=0, n_bytes=0,
idle_age=2345, dl_vlan=1 actions=strip_vlan,set_tunnel:0x3e9,output:2

4. here is the local.conf I used for compute node
enable_service odl-compute

please let me know if there's any info I need provide, thanks.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstack.org/pipermail/openstack/attachments/20140515/311f571e/attachment.html>

More information about the Openstack mailing list