[Openstack] Attaching FloatingIP to VM

Guilherme Russi luisguilherme.cr at gmail.com
Thu Sep 19 18:46:31 UTC 2013

Hello again Rahul, any idea about what i should do? Should i create the
public network from demo user?

Thank you.

2013/9/18 Guilherme Russi <luisguilherme.cr at gmail.com>

> Hey Rahul,
>  I've tried to create the public network again and now I put the --shared
> when I typed the command to create it, but the same way I still get the
> error message. Do I need to create another credential to my demo user? I
> had a grizzly version installed before I format my controller node and it
> worked fine.
> Thank you.
> Regards.
> 2013/9/16 Rahul Sharma <rahulsharmaait at gmail.com>
>> Hi Guilherme,
>> If you will source these credentials, then you will be able to perform
>> operations on admin tenant and not on the demo tenant. For demo tenant, you
>> need to change the OS_TENANT_NAME to demo. You would have created networks
>> and ports using these credentials during installation, now you would be
>> able to assign floating-ip's to vm's or ports of tenant "admin". For demo
>> user, you need to share that network with demo  tenant. Try and check if it
>> works. Floating-ip is from the external network and it would be shared. If
>> it doesn't work, try deleting the existing networks and creating again
>> using UI if possible.
>> --Rahul
>> On Tue, Sep 17, 2013 at 1:05 AM, Guilherme Russi <
>> luisguilherme.cr at gmail.com> wrote:
>>> Hello Rahul, here are my credentials:
>>> export OS_TENANT_NAME=admin
>>> export OS_USERNAME=admin
>>> export OS_PASSWORD=password
>>> export OS_AUTH_URL="http://localhost:35357/v2.0/"
>>> export OS_SERVICE_ENDPOINT="http://localhost:35357/v2.0"
>>> export OS_SERVICE_TOKEN=password
>>> Do I need credentials to demo user too? I had another installation,
>>> before reinstall my ubuntu again, and my credentials were like this and I
>>> could allocate floating ip.
>>> Regards.
>>> 2013/9/16 Rahul Sharma <rahulsharmaait at gmail.com>
>>>> Hi Guilherme,
>>>> I am not sure but I have a wild guess that you might have created the
>>>> port using admin user and allocated floating-ip using demo user.  If you
>>>> are using CLI, then what are the parameters you have sourced using
>>>> openrc/localrc? Have you sourced the correct tenant's credentials i.e. of
>>>> admin's or of demo's? Sometimes, we make mistakes in sourcing the wrong
>>>> credentials, hence making the guess.
>>>> -Regards
>>>> Rahul
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstack.org/pipermail/openstack/attachments/20130919/a9bff110/attachment.html>

More information about the Openstack mailing list