[Openstack] grizzly+brooklyn(jcloud) restapi call+network error

Molnár Mihály László lacikaaa at gmail.com
Wed Oct 30 16:54:35 UTC 2013

ok, looks like i found the error. I added the ext_net with the wrong tenant
id. It was the actual tenants id, not the admin's. Because of this OS added
ext_net to the instance. The instance tried to get IP for the ext_net
interface first, but because there is no dhcp it hangs there.
I removed the ext_net totally, so there is only one network, now its
Next step to put back the ext_net with admin tenant id and test again.


On Wed, Oct 30, 2013 at 11:36 AM, Molnár Mihály László
<lacikaaa at gmail.com>wrote:

> Hi!
> I have a Grizzly installation with Quantum (neutron) gre tunneling based
> on this:
> https://github.com/mseknibilel/OpenStack-Grizzly-Install-Guide/blob/OVS_MultiNode/OpenStack_Grizzly_Install_Guide.rst
> It's working without problem when I use Horizon.
> I want to use brooklyn - http://brooklyncentral.github.io/index.html -
> which uses jClouds - http://jclouds.incubator.apache.org/- to create
> instances.
> In brooklyn I couldn't find a way to define the network for my instance,
> but as I can see in Horizon, in this case OpenStack adds both of my
> networks, the tenant's net and the external net. I can see the IPs in
> horizon, but eventually my instance doesn't get any IP address. If I define
> both networks in horizon and try to create my instance then its working, so
> there is something wrong.
> I checked the RestApi calls:
> Working, from horizon:
> {"server": {"name": "Ubuntu", "imageRef":
> "a8c46c40-e0f8-4904-a21f-46901be91f4f", "key_name": "key", "flavorRef":
> "2", "max_count": 1, "min_count": 1, "networks": [{"uuid":
> "ff74b46a-1ab4-4a97-91c7-21c95485aa34"}, {"uuid":
> "49aa37da-29c8-4314-b575-d705771b5361"}], "security_groups": [{"name":
> "default"}]}}
> Not working, from brooklyn/jcloud:
> {"server":{"name":"br-ujpm-dipl-kryi-ou9w-336","imageRef":"a8c46c40-e0f8-4904-a21f-46901be91f4f","flavorRef":"2","key_name":"key","security_groups":[{"name":"default"}]}}
> So as you can see the main difference is that there is no networks in the
> restapi call from brooklyn and somehow this cause a mysterious problem in
> the networking.
> I tried these calls from RESTClient -
> https://addons.mozilla.org/En-us/firefox/addon/restclient/ - and I got
> the same results, so its working if I send networks in the restapi post,
> and it fails if i dont.
> I have only problem with the networking part, the instances are created
> successfully.
> Any idea what could go wrong or where should I check? How can I define
> which network should the instance join if there is no network defined? Its
> not ideal to join it to the ext net if there is no network defined...
> Thanks!
> Rusty
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstack.org/pipermail/openstack/attachments/20131030/b9a1e453/attachment.html>

More information about the Openstack mailing list