[Openstack] Can't connect to RabbitMQ

Florian Lindner mailinglists at xgm.de
Mon Oct 28 18:40:35 UTC 2013


I've installed OpenStack on a Ubuntu 12.04 VM according to the install guide. 
It worked fine until I created the compute node on a second VM and tried to set 
up nova networking:

# nova network-create vmnet --fixed-range-v4= --bridge-
interface=br100 --multi-host=T

just does nothing until canceled. I tried on the controller and compute1 node.

nova-api.log shows:

ERROR nova.openstack.common.rpc.common AMQP server on controller:5672 is 
unreachable: Socket closed. Trying again in 1 seconds.
INFO nova.openstack.common.rpc.common Reconnecting to AMQP server on 

controller:~# netstat -lpn | grep beam
tcp        0      0 *               LISTEN      
tcp6       0      0 :::5672                 :::*                    LISTEN      

It listens on this port, but IPv6. IMO on linux listing on an IPv6 port also 
means listening on the same v4 port.

What's wrong with the installation?

Thanks a lot!


More information about the Openstack mailing list