[Openstack] [OpenStack][Neutron] Cleanup of network namespaces not happening

raghavendra.lad at accenture.com raghavendra.lad at accenture.com
Fri Jul 26 03:43:55 UTC 2013


I have installed Openstack Grizzly ubuntu 12.04 still floating IPs alloting issue and cannot ssh into VM any thoughts please share.
I have followed the multi node install of Msknebil and found error while creating volume.   I would like to know the path that was discussed in @etc at rc.local file any key ideas  plz share.
Raghavendra Lad
-----Original message-----
From: Balamurugan V G
Sent:  25/07/2013, 10:28  PM
To: openstack at lists.launchpad.net
Subject: [Openstack] [OpenStack][Neutron] Cleanup of network namespaces not happening


I have a 3 nodes Grizzly 2013.1.1 setup and I see that the network namespaces are not getting deleted even after the networks/subnets are deleted. When I run 'quantum-netns-cleanup', I get the following error:

root at openstack-dev-network:~# quantum-netns-cleanup
2013-07-25 12:51:25 CRITICAL [quantum]
Command: ['sudo', 'ip', 'netns', 'exec', 'qdhcp-b9c30f80-8643-4a20-b43c-1f3d861eea63', 'ip', '-o', 'link', 'list']
Exit code: 1
Stdout: ''
Stderr: 'seting the network namespace failed: Invalid argument\n'
root at openstack-dev-network:~#

I see that there are number of bugs reports on this issue but non seem to have been addressed. For example, the ones at:


I tried the patch in the first bug above and also added root_helper in /etc/quantum/dhcp_agent.ini but to no luck.

Has anyone got this issues fixed?


This message is for the designated recipient only and may contain privileged, proprietary, or otherwise confidential information. If you have received it in error, please notify the sender immediately and delete the original. Any other use of the e-mail by you is prohibited.

Where allowed by local law, electronic communications with Accenture and its affiliates, including e-mail and instant messaging (including content), may be scanned by our systems for the purposes of information security and assessment of internal compliance with Accenture policy.


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstack.org/pipermail/openstack/attachments/20130726/8fe6db6c/attachment.html>

More information about the Openstack mailing list