[Openstack] setup linux users

Gonfi den Tschal gonfidentschal at gmail.com
Fri Jul 5 21:57:10 UTC 2013

thanks, made some progress.
this user had the same problem
https://answers.launchpad.net/swift/+question/201810 i've now apt-get
removed swift, and then installed all from git. that worked.
except there are 2 failing unit tests, something about differences in
expected http return codes.

after this all my config files are now confused with the user. wherever i
had set 'swift' as the user, it's now overwritten to 'myuser'. even in
those places where the manual had 'swift' hardcoded, not
'<your-user-name>'. so i still don't know if <your-user-name> is supposed
to be my non-root with-login user, or my no-login user named swift.
i'm now trying to change all files to have 'swift' in there in all places.

On Fri, Jul 5, 2013 at 6:47 PM, nithish B <bestofnithish at gmail.com> wrote:

> Hi,
>     You have to be root to get the user part right.
> i.e. myuser at mymachine:~$sudo su
> myuser at mymachine:~#cd bin
> myuser at mymachine:~/bin$remakerings
> And as for the second one, try,
> $sudo apt-get update
> $sudo apt-get install python-swiftclient
> If it doesn't work, download the package from
> mirror.pnl.gov/ubuntu//pool/main/p/python-swiftclient/python-swiftclient_1.2.0-0ubuntu2_all.deb
> and install it using dpkg manager.
> Regards,
> Nitish B.
> On Fri, Jul 5, 2013 at 10:09 AM, Gonfi den Tschal <
> gonfidentschal at gmail.com> wrote:
>> i'm having some difficulties following the tutorial at
>> http://docs.openstack.org/developer/swift/development_saio.html
>> 1) the user:
>> i don't understand how it's meant, i guessed:
>>  - root for the commands
>>  - <your-user-name> should be "swift", a user account without login
>> privileges, created as:
>>    useradd -s /usr/sbin/nologin swift
>>  - some standard user with login where the ~/bin stuff goes
>> because the text says "Swift processes also run under a separate user and
>> group" (separate, so not the same as my user).
>> "which may not exist on your system" confusing also, does it mean it does
>> not need to be created? or that it probably does not exist yet, and i
>> should create it?
>> i've used the standard user to run the commands with sudo. but then i got
>> stuck with setting up scripts when running them as my login user (not swift
>> user), i got:
>> myuser at mymachine:~/bin$ remakerings
>> Traceback (most recent call last):
>>   File "/usr/bin/swift-ring-builder", line 676, in <module>
>>     mkdir(backup_dir)
>> OSError: [Errno 13] Permission denied: 'backups'
>> Ring Builder file does not exist: object.builder
>> ...
>> so: should the swift user be a standard user, and also run the scripts?
>> 2) i don't want to get a dev version of the code, so i've followed the
>> install instructions from
>> http://docs.openstack.org/developer/swift/howto_installmultinode.html
>> installing swift worked, but not python-swiftclient:
>> myuser at mymachine:~/bin$ sudo apt-get install python-swiftclient
>> Reading package lists... Done
>> Building dependency tree
>> Reading state information... Done
>> E: Unable to locate package python-swiftclient
>> 3) i'm setting up a vm to be used for development, but i'll also clone it
>> to use it for the early stage of the running live app. is there a better
>> tutorial somewhere?
>> thanks,
>> gonfi
>> _______________________________________________
>> Mailing list: https://launchpad.net/~openstack
>> Post to     : openstack at lists.launchpad.net
>> Unsubscribe : https://launchpad.net/~openstack
>> More help   : https://help.launchpad.net/ListHelp
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstack.org/pipermail/openstack/attachments/20130706/4f4766b5/attachment.html>

More information about the Openstack mailing list