[Openstack] can not access vm via vnc(grizzly)

Wangpan hzwangpan at corp.netease.com
Tue Jul 30 03:32:15 UTC 2013

what the result of CLI `virsh dumpxml ${instance-uuid}` execute on the host which instance is running?



发件人:sam lee <lixq2000 at gmail.com>
发送时间:2013-07-30 11:23
主题:Re: [Openstack] can not access vm via vnc(grizzly)
收件人:"Mahardhika"<mahardika.gilang at andalabs.com>
抄送:"Wangpan"<hzwangpan at corp.netease.com>,"openstack"<openstack at lists.openstack.org>

No application listening 5900 on compute node. 

2013/7/30 Mahardhika <mahardika.gilang at andalabs.com>

You should check on machine that running compute node (nova-compute), it will be /qemu-system-x 
#netstat -tulpn

On 7/30/2013 9:52 AM, sam lee wrote:

I doesn't find any application listening port 5900 on controller node, Do I miss something?

2013/7/29 Wangpan <hzwangpan at corp.netease.com>

vnc is supported by qemu, so we needn't to install a vnc-server into instance.
you may check the vnc connection by connecting it directly on the host by a vnc client,
1. virsh dumpxml ${instance-uuid}
2. get the vnc port: like 5900 or 59XX
3. get the vnc bind address: like or as the vncserver_listen = in nova.conf)
4. make a port forwarding to the host by ssh and set the proxy in vnc client if your vncserver_listen =
5. set the target ip address to the host of instance and the vnc port 59XX to the vnc client and connect to the instance

<graphics type='vnc' port='5900' autoport='yes' listen='' keymap='en-us'>
      <listen type='address' address=''/>

if this is ok, then may be the vncproxy type you config is wrong, there are two types :'novnc' and 'xvpvnc', and in my env, the 'novnc' is used,
the novnc service need be installed on the host,
then you can get the vnc-console by 'nova get-vnc-console ${instance-uuid} novnc',
hzwangpan at myhost:~$ nova get-vnc-console e4975b9f-95d0-4223-8df9-7d4f017b5de7 novnc
| Type  | Url                                                                                 |
| novnc | http://xxx.xxx.xxx.xxx:6080/vnc_auto.html?token=45fc8fc6-4488-4b4f-9b20-53de67d9ef8d |
the ip of Url is same as the config novncproxy_base_url = http://xxx.xxx.xxx.xxx:6080/vnc_auto.html in the nova.conf.
then you can try to open the url in the browser like google chrome of firefox(html5/websocket should be supported).
the vnc console will be open if there is no error.



发件人:Mahardhika <mahardika.gilang at andalabs.com>
发送时间:2013-07-29 16:07
主题:Re: [Openstack] can not access vm via vnc(grizzly)
收件人:"sam lee"<lixq2000 at gmail.com>,"openstack"<openstack at lists.openstack.org>

Have you tried to used console on horizon dashboard? vnc must be installed on instance first, like tiger-vnc
On 7/29/2013 2:53 PM, sam lee wrote:


2013/7/29 Mahardhika <mahardika.gilang at andalabs.com>

Does the nova novnc start well? 

On 7/29/2013 2:14 PM, sam lee wrote:

Hi all, 

        I am installing openstack grizzly on redhat 6.4. when I created a instances successfully and tried to access it via vnc, it had no response. the log file xvpvncproxy.log shows an error as below:

User-Agent: Mozilla/5.0 (Windows NT 6.1) AppleWebKit/537.31 (KHTML, like Gecko) Chrome/26.0.1410.64 Safari/537.31
2013-07-29 10:35:18.231 3111 INFO nova.XCP VNC Proxy.wsgi.server [-] Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/eventlet/wsgi.py", line 393, in handle_one_response
    for data in result:
TypeError: 'NoneType' object is not iterable

Anyone has encountered the same question before? thanks in advance.


Mailing list: http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack
Post to     : openstack at lists.openstack.org
Unsubscribe : http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack

Mahardhika Gilang

PT. Andalabs Technology 
Gedung Gravira
Jl. Cideng Barat no. 54
Jakarta Pusat 10150

HP : 0852 139 55861
Email : mahardika.gilang at andalabs.com 
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstack.org/pipermail/openstack/attachments/20130730/be7ad309/attachment.html>

More information about the Openstack mailing list