[Openstack] devstack won't startup nova-api

Jessica Lucci jessica.lucci at RACKSPACE.COM
Mon Aug 5 19:07:08 UTC 2013

I tried to run devstack on an Ubuntu 12.04 64 bit install yesterday, and got the same error. There's an issue with the way devstack determines general dependencies from the combined dependencies of all the openstack projects. I think nova changed some dependencies recently, and devstack hasn't quite caught up to those changes yet.

On Aug 5, 2013, at 1:31 PM, Dean Troyer <dtroyer at gmail.com>

> On Mon, Aug 5, 2013 at 1:10 PM, Steve Sonnenberg <steveisoft at gmail.com> wrote:
>> Can anyone explain why I can't get a brand new devstack install up an
>> running.
> Which OS? There are still some known problems on Fedora and RHEL while
> we sort out the python dependency conflicts, although I haven't seen
> that particular failure yet.
> dt
> -- 
> Dean Troyer
> dtroyer at gmail.com
> _______________________________________________
> Mailing list: http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack
> Post to     : openstack at lists.openstack.org
> Unsubscribe : http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack

More information about the Openstack mailing list