[Openstack] Connectivity issue from within the Instances

Martinx - ジェームズ thiagocmartinsc at gmail.com
Mon Aug 5 06:32:29 UTC 2013


I followed this guide:
build my latest cloud (PoC) and, from within my Instances, I'm facing some
connectivity issues, like this:

Instance ip config
ubuntu at ubu-1:~$ ip r
default via dev eth0  metric 100 dev eth0  proto kernel  scope link  src

Test #1 - ping google - okay...
root at ubu-1:~# ping -c 1 google.com
PING google.com ( 56(84) bytes of data.
64 bytes from gru03s08-in-f14.1e100.net ( icmp_req=1 ttl=57
time=75.7 ms

Test #2 - install ruby gem "bundler" - not okay...
root at ubu-1:~# gem install bundler
ERROR:  While executing gem ... (Gem::RemoteFetcher::FetchError)
    too many connection resets (

Also, I can ping rubygems server, look:

root at cir-1:~# ping production.cf.rubygems.org
PING d2chzxaqi4y7f8.cloudfront.net ( 56(84) bytes of data.
64 bytes from server-54-230-58-161.gru1.r.cloudfront.net (
icmp_req=1 ttl=56 time=5.09 ms

And I can telnet it too!

root at cir-1:~# telnet production.cf.rubygems.org 80
Connected to d2chzxaqi4y7f8.cloudfront.net.
Escape character is '^]'.

But "gem install bundler" always fails...

>From within ubu-1's gateway, the "network node" with l3 agent + namespaces,
"gem install bundler" works as expected...

Weird thing is, I can run "apt-get update / upgrade" without any issues on
"ubu-1" instance... Everything is just opened to the Internet...

All tenants have this weird problem... I tried different setups but, can't
figure it out by myself... I appreciate any help!

I'm running tcpdump at the network node, while trying to run "gem install
bundler" from within "ubu-1" instance:

root at network:~# ip netns exec qrouter-475257b2-836c-43a1-98a8-8f29ae1ce1b5
tcpdump -i qr-7a44c1d0-7e

02:27:42.279268 IP > server-54-230-58-171.gru1.r.cloudfront.net:
ICMP unreachable - need to frag (mtu 1454), length 556

more on paste bin:


>From within network node (ubu-1 instance gateway), gem install it works...

root at network:~# gem install bundler
Fetching: bundler-1.3.5.gem (100%)
Successfully installed bundler-1.3.5
1 gem installed
Installing ri documentation for bundler-1.3.5...
Installing RDoc documentation for bundler-1.3.5...

Any thoughts?! Apparently, the package didn't goes back to the Instance...
But I don't know how to fix it...    =P

I tried a lots of variants of this setup (playing with quantum networks,
routers and Floating IPs) but, no success... I can't run "gem install
bundler" form within any Instance... But I can navigate, use apt-get update
and etc...    :-/

NOTE: I noted that the rubygems is hosted at the AWS + CloudFront, and, the
IP of it keep changing... It differs a bit from this mail and pastebin that
I posted.

NOTE 2: The ubu-1 have no Floating IP attached to it, I'm trying to run
"gem install bundler" from VNC console after changing "ubuntu" user
password... Everything here is based on Ubuntu 12.04.2 + Grizzly from UCA,
including Instances (ubu-1) and servers (network, controller, node, etc)...

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstack.org/pipermail/openstack/attachments/20130805/1f00715d/attachment.html>

More information about the Openstack mailing list