[Openstack] Multinode installation (with devstack on the master)

Frost Dragon frostdragon777 at gmail.com
Thu Dec 29 06:00:12 UTC 2011

    I set up openstack on my second node with devstack as suggested. I
could launch instances from the dashboard on the master node but couldn't
view the vms on the second node with the VNC console in the dashboard. But
the VNC console worked fine with instances launched on the master. On my
laptop (with an ip of, i did the following:

route add default gw (master node's public ip) - i did this to
access the private ips from my laptop
vncviewer (master node's private ip) - i could view the VM i
launched on this node and i could ping my public network with this
vncviewer (second node's private ip) - i could view the VM
running on this node but i couldn't ping other VMs and the public, private

    I think the problem is in my second node's network configuration. It
has two NICs but only one of them is connected (eth1 with an ip of Unlike the master node, eth0 is not connected to the public
network on this node. nova.conf has the following parameters which i think
may be the cause of this problem:


    In this case, how should i tweak my localrc file to get network access
for my VMs? I have setup SNAT on the master node to provide external
network access to machines in the network All my VMs are
given ips in the fixed range

    Regarding crowbar, I haven't tried it yet. Once I read more about it,
I'll give it a shot.

Thanks and regards,
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstack.org/pipermail/openstack/attachments/20111229/c93abdff/attachment.html>

More information about the Openstack mailing list