Thomas Goirand thomas at goirand.fr
Thu Dec 29 05:24:36 UTC 2011

On 12/29/2011 10:40 AM, Ewan Mellor wrote:
> You need chmod a+x /etc/xapi.d/plugins/*
> If you just want to install a package, Xen.org are building an RPM
> for XenServer / XCP with these plugins:
> http://downloads.xen.org/XCP/openstack/openstack-xen-plugins/.
> Cheers,
> Ewan.


Thanks, but that's not what I'm trying to do here. I'm not interested in
the RPM packages at all. I had a quick look though, in this package.

I'm working on the Debian packaging of both XCP and OpenStack. I worked
closely with Mike and Jon from Citrix, and last week, I uploaded XCP  in
Debian SID (that would be the first milestone of the project Kronos).
I'm currently modifying nova packaging so that these files are packaged
in a convenient "nova-xcp-pluggins".

I have found out (by myself) that the plugin directory in Debian isn't:

but rather:

which indeed makes a lot more sense in a packaged, FHS respecting,
environment, and I know both Jon and Mike worked on that.

Now, I'm having another error though:
(nova): TRACE: Failure: ['XENAPI_PLUGIN_FAILURE', 'host_data',
'IOError', "[Errno 2] No such file or directory: '/usr/etc/xenhost.conf'"]

I don't really mind the path issue (the issue is in the xenhost python
script, I can fix it and set it to /etc/xcp/xenhost.conf instead), but
what does the plugin expect to see in this file?


More information about the Openstack mailing list