[Openstack] quantum error (essex-2)

Brad Hall brad at nicira.com
Wed Dec 21 05:19:53 UTC 2011


Are you sure you're not mixing versions here?  It souds like something in your
python path has gone wrong.

(why is python looking in /opt/horizon/... when you're starting
quantum-server?)

On Wed, Dec 21, 2011 at 12:18:33PM +0800, darkfower wrote:
> hi brad,
> 
>  The inside of the horizon pip-requires wrote -e git+
> https://github.com/openstack/quantum.git@stable/diablo#egg=quantum
> 
>   But github. Com openstack project quantum of the use of master´╝îwhen boot
> quantum-server,error as flollow:
> 
> Got: ImportError("<module 'quantum.api' from
> '/opt/horizon-2012.1/openstack-dashboard/tools/src/quantum/quantum/api/__init__.pyc'>
> has no 'APIRouterV11' attribute",)
> 
> 2011/12/21 Brad Hall <brad at nicira.com>:
> > Hi darkfower,
> >
> > Currently you have to do python setup_x.py develop where x corresponds
> > to the package you want to do that for (server, client, common, etc).
> > This will be changing soon (I've got a patchset for review that
> > converts our setup.py into a real one).
> >
> > Thanks,
> > Brad
> >
> > On Tue, Dec 20, 2011 at 5:26 PM, darkfower <atkisc at gmail.com> wrote:
> >> hi, everybody
> >>
> >>   when i exec python setup.py develop in the quantum dir , error as
> follow :
> >>
> >>    Checking for virtual-env and easy_install
> >>   done.
> >>   Command 'develop' not found
> >>
> >>
> >>
> >>   can i help me ?
> >>
> >> _______________________________________________
> >> Mailing list: https://launchpad.net/~openstack
> >> Post to     : openstack at lists.launchpad.net
> >> Unsubscribe : https://launchpad.net/~openstack
> >> More help   : https://help.launchpad.net/ListHelp




More information about the Openstack mailing list