[Openstack-operators] Nova live-migration failing for RHEL7/CentOS7 VMs

Mike Smith mismith at overstock.com
Wed Sep 28 15:15:57 UTC 2016

William -

That is probably what you have hit then.  There are several bug tickets out there that are related, I don’t have the specific one I found handy but it’s similar to the one Marcus just posted.  I found it by Googling around for the error late one night.

In our case, we had most of our hypervisors on the 1.5.3-105.el7_2.4 version but had a couple of new ones that ended up with 1.5.3-105.el7_2.7.  Migrating to those new hypervisors resulted in the VMs being shut down, but migrating from the new to the old worked fine.  So for my case I live-migrated all the VMs from the new compute hosts to the old ones, did the yum downgrade of those packages on the new hosts, and then rebooted those hosts for good measure.  After that I no longer had the problem.

Good luck!

Mike Smith
Lead Cloud Systems Architect

On Sep 28, 2016, at 8:55 AM, William Josefsson <william.josefson at gmail.com<mailto:william.josefson at gmail.com>> wrote:

thanks Mike! yes, I checked and I've got the versions you mentioned installed:

yum list installed | grep "qemu-"
qemu-img.x86_64                   10:1.5.3-105.el7_2.7     @updates
qemu-kvm.x86_64                  10:1.5.3-105.el7_2.7     @updates
qemu-kvm-common.x86_64   10:1.5.3-105.el7_2.7     @updates

Is there any reference or bugzilla ticket for this issue, or how did you track it down?

Can you also please advice on the command: "yum downgrade qemu-kvm qemu-kvm-common qemu-img”   as I'm having running VMs in my environment, do I need to restart libvirtd after this, and would it affect any of my instances? thx will

On Wed, Sep 28, 2016 at 10:47 PM, Mike Smith <mismith at overstock.com<mailto:mismith at overstock.com>> wrote:
There is a bug in the following:


Are you running these versions?  We encountered this same issue and fixed it by running "yum downgrade qemu-kvm qemu-kvm-common qemu-img” which took us back to the el7_2.4

Mike Smith
Lead Cloud Systems Architect

On Sep 28, 2016, at 8:30 AM, William Josefsson <william.josefson at gmail.com<mailto:william.josefson at gmail.com>> wrote:


I have problems with nova live-migration for my CentOS7 and RHEL7 VMs.   The live migrations works fine for Windows2012R2 and Ubuntu1404 VMs.

For CentOS7/RHEL based images I get this error in the Destination node in nova-compute.log. Also console for logged in VM users on the VM freeze.

2016-09-28 10:49:24.101 353935 INFO nova.compute.manager [instance: cd0b605d] VM Resumed (Lifecycle Event)
2016-09-28 10:49:24.339 353935 INFO nova.compute.manager [instance: cd0b605d] VM Resumed (Lifecycle Event)
2016-09-28 10:49:25.866 353935 INFO nova.compute.manager [instance: cd0b605d] Post operation of migration started
2016-09-28 10:49:39.410 353935 INFO nova.compute.manager [instance: cd0b605d] VM Stopped (Lifecycle Event)
2016-09-28 10:49:39.532 353935 WARNING nova.compute.manager [instance: cd0b605d] Instance shutdown by itself. Calling the stop API. Current vm_state: active, current task_state: None, original DB power_state: 4, current VM power_state: 4
2016-09-28 10:49:39.668 353935 INFO nova.compute.manager [instance: cd0b605d] Instance is already powered off in the hypervisor when stop is called.
2016-09-28 10:49:39.736 353935 INFO nova.virt.libvirt.driver [instance: cd0b605d] Instance already shutdown.
2016-09-28 10:49:39.743 353935 INFO nova.virt.libvirt.driver [instance: cd0b605d] Instance destroyed successfully.

Eventually the VM ends up in SHUTDOWN state on the destination node.

I'm on CentOS7/Liberty, and my storage backend is CEPH(Hammer 0.94.9).

Please advice. thx will
OpenStack-operators mailing list
OpenStack-operators at lists.openstack.org<mailto:OpenStack-operators at lists.openstack.org>


CONFIDENTIALITY NOTICE: This message is intended only for the use and review of the individual or entity to which it is addressed and may contain information that is privileged and confidential. If the reader of this message is not the intended recipient, or the employee or agent responsible for delivering the message solely to the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this communication in error, please notify sender immediately by telephone or return email. Thank you.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstack.org/pipermail/openstack-operators/attachments/20160928/db7e9f19/attachment.html>

More information about the OpenStack-operators mailing list