[Openstack-operators] chef

aishwarya.adyanthaya at accenture.com aishwarya.adyanthaya at accenture.com
Fri May 15 11:12:02 UTC 2015


Yes, when I issued the command to create a node I was able to view it in my dashboard and also thorough my cli by 'knife openstack server list' command. I'm able to ssh to the node without any problem but the create command gives an error even though the node is created. The next step is the knife bootstrap which gives an error of course.

This is what I've tried: Chef-server version for 14.04: chef-server-core_12.0.4-1_amd64.deb and Openstack- Juno version

Steps what I've been following are:
/etc/hosts       localhost       # If the localhost is commented the chef-server-ctl reconfigure gets into an error.
x.x.x.x         chef-server

dpkg -i chef-server-core_12.0.4-1_amd64.deb
chef-server-ctl reconfigure

Note: The error I get when the localhost is commented out is---
Recipe: private-chef::oc_id
  * runit_service[oc_id] action restart
    Error executing action `restart` on resource 'runit_service[oc_id]'
    Expected process to exit with [0], but received '1'

And even if I do get through this step by uncommenting the section in the /etc/hosts I'm unable to view the GUI of my web server as it reads: "Chef Server API
This is the main endpoint for all of the Chef APIs. In general, none of these have any HTML representations, and the vast majority of them require that you are sending properly authenticated requests. So while it's neat that you came to visit, you probably won't find what you are looking for here". I restarted all the chef services to make sure they were running and they ran fine. Wondering if it was because I didn't run the command: chef-server ctl install opscode-manage but there was an error similar to the above mentioned error.

Therefore I used the package of 11.0.1 of chef-server with my juno openstack following the link: http://www.bogotobogo.com/DevOps/Chef/Chef_Client_Node_Knife_Bootstraping_a_Node_on_EC2_ubuntu_14_04.php The only difference is I've made use of openstack instead of EC2 but at the end I've encountered similar error to what the document has got.

Aishwarya Adyanthaya


> On May 14, 2015, at 1:21 AM, aishwarya.adyanthaya at accenture.com wrote:
> Hi J,
> I ran the command 'knife node list' and found the list to be empty while the 'knife client list' command displays chef-validator and chef-webui. It seems like when I was creating the node through  knife openstack server create the node got launched successfully in the dashboard and I'm able to ssh the node but the command gives error as:
> Waiting for sshd to host
> (x.x.x.x).............................................................
> ....done Doing old-style registration with the validation key at
> /root/chef-repo/.chef/chef-validator.pem...
> Delete your validation key in order to use your user credentials
> instead
> Connecting to x.x.x.x
> FATAL: Check if --bootstrap-protocol and --image-os-type is correct.
> connection closed by remote host
> ERROR: Net::SSH::Disconnect: Check if --bootstrap-protocol and
> --image-os-type is correct. connection closed by remote host
> The command I'm using to create the node is:
> knife openstack server create -f 2 -I ubuntu_image -a
> external_id--network-ids alphanumeric_id -S chef_key -N node_name

I’m at a loss here. If this is a Ubuntu box, neither of the —bootstrap-protocol or the —image-os-type should be even checked. This is also failing because the connection was closed, so thats pointing to your vm on the in your OpenStack instance. Do you have any networking oddities between your workstation and this vm and cloud?

Also, i’m hoping that “ubuntu_image” is you scrubbing your UUID, because I’ve seen some issues with using the “easy name” in Juno. I’m pretty sure it was resolved in the 1.0.0 release though.

Actually yeah i don’t know what version of the OpenStack are you running against? Is this a major public cloud or is it in-house?

I’ve personally tested the knife-openstack 1.1.0 against a couple major public clouds, devstack, and the Chef cookbook built OpenStack instance so I know we have a good coverage.

You said you can SSH into the box, that’s good, so also lets take a step back. Can you provision a machine with knife openstack server create? When you do, do you see it pop up in nova list or the horizon dashboard? If so, then we can determine that the creation is working and we can move forward with the network connection and bootstrapping.

In very simple terms the bootstrap literally SSHs into the box, pulls down chef, moves up the validation key and then runs chef-client. If you can SSH to it from the box you run your knife commands from, then there is no reason why this shouldn’t work.

Anyway, this is the best i got via email, i’m curious to see if any of this helps you, -JJ


This message is for the designated recipient only and may contain privileged, proprietary, or otherwise confidential information. If you have received it in error, please notify the sender immediately and delete the original. Any other use of the e-mail by you is prohibited. Where allowed by local law, electronic communications with Accenture and its affiliates, including e-mail and instant messaging (including content), may be scanned by our systems for the purposes of information security and assessment of internal compliance with Accenture policy.


More information about the OpenStack-operators mailing list