[Openstack-operators] Verifying Swift - X-Auth problem

Adam Lawson alawson at aqorn.com
Thu Feb 6 21:57:02 UTC 2014

Hey OpenStack peeps!

I'm trying to verify a Swift manual installation with 1x proxy and 5x
storage nodes. I turned on all services with no errors (well, no errors I
didn't fix anyway).
My problem is with trying to create an account and heading it. Below is
what I'm scripting as I go along.

I executed Step1 successfully using system:root as the user. But when I
executed Step2, I received a 401 Unauthorized reply.
Undaunted I executed Step3 which produced nothing. I then tried running
Step1 again as shown below with test:tester as the user (thinking it was
because I don't actually run as root but I run commands via sudo) and now
it always gives me 401 unauthorized replies.

Is this an obvious problem with an easy remedy?

# 1 Aqcuire X-Storage-Url and X-Auth-Token
> curl -k -v -H 'X-Storage-User: test:tester' -H 'X-Storage-Pass: testing'
> https://$PROXY_LOCAL_NET_IP:8080/auth/v1.0

# 2 Test HEAD account process
> # SAMPLE: curl -k -v -H 'X-Auth-Token: <token-from-x-auth-token-above>'
> <url-from-x-storage-url-above>
> curl -k -v -H 'X-Auth-Token: AUTH_tkf85b7788c36143ac99e5a5b42d95d628'
> https://$PROXY_LOCAL_NET_IP:8080/v1/AUTH_system

# Test Swift is actually working
> swift -A https://$PROXY_LOCAL_NET_IP:8080/auth/v1.0 -U system:testuser -K
> testpass stat


*Adam Lawson*
427 North Tatnall Street
Ste. 58461
Wilmington, Delaware 19801-2230
Toll-free: (888) 406-7620
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstack.org/pipermail/openstack-operators/attachments/20140206/b360b92e/attachment.html>

More information about the OpenStack-operators mailing list