[Openstack-operators] I shot myself in the foot trying to install the block storage service

Razique Mahroua razique.mahroua at gmail.com
Wed Aug 6 01:11:56 UTC 2014

You can simply run a SQL query based on the service ID:

use keystone;
UPDATE endpoints SET adminURL=“etc…. WHERE service=“ID”;

I don’t remember the exact name of the fields, but it’s the simplest option IMO

On 05 Aug 2014, at 18:05, Fischer, Matt <matthew.fischer at twcable.com> wrote:

> Yes, you've messed it up good. When the endpoint URL is bad Keystone cannot do anything. I filed a bug on this last week and the fix is being back ported. The only resolution that I know of is to fix the endpoint in the Keystone database. I think based on what I see that you're missing an "s" on the end of that. %(foo)s is how python does string substitution. Here's how I fixed it before:
> http://www.mattfischer.com/blog/?p=532
> From: Jeff Silverman <jeff at sweetlabs.com>
> Date: Tuesday, August 5, 2014 6:42 PM
> To: "openstack-operators at lists.openstack.org" <openstack-operators at lists.openstack.org>
> Subject: [Openstack-operators] I shot myself in the foot trying to install the block storage service
> I am in http://docs.openstack.org/icehouse/install-guide/install/yum/content/cinder-controller.html  step 8. The problem began when I didn't notice that the word controller was in italics in the documentation. I wish it were in ALL CAPS, such as for the CINDER_PASS/. However, I went back and repeated the commands correctly, I think, and I am still getting a 500 internal server error.
> I used keystone with the --debug switch and tried using the generated curl command:
> root at controller1-prod.controller1-prod:~# curl -i -X POST http://controller1-prod.sea.opencandy.com:35357/v2.0/tokens -H "Content-Type: application/json" -H "Accept: application/json" -H "User-Agent: python-keystoneclient" \
> -d '{"auth": {"tenantName": "admin", "passwordCredentials": {"username": "admin", "password": "f8d67f756e057918ef25dca59de79778"}}}'
> HTTP/1.1 500 Internal Server Error
> Vary: X-Auth-Token
> Content-Type: application/json
> Date: Tue, 05 Aug 2014 23:51:10 GMT
> Transfer-Encoding: chunked
> {"error": {"message": "Malformed endpoint URL (see ERROR log for details):http://controller:8776/v1/%(tenant_id)", "code": 500, "title": "Internal Server Error"}}root at controller1-prod.controller1-prod:~#
> from /var/log/keystone/keystone.log:
> 2014-08-05 16:51:10 ERROR [keystone.catalog.core] Malformed endpoint http://controller:8776/v1/%(tenant_id) - incomplete format (are you missing a type notifier ?)
> 2014-08-05 16:51:10 WARNING [keystone.common.wsgi] Malformed endpoint URL (see ERROR log for details): http://controller:8776/v1/%(tenant_id)
> I looked at the transfer with wireshark and I confirm that the service endpoint is really sending http://controller:8776 in the error message. I don't know what port 8776 or why the server thinks that there is traffic on port 8776.
> Whatever I did wrong, it has messed up keystone but good:
> # keystone catalog
> Traceback (most recent call last):
>   File "/usr/lib/python2.6/site-packages/keystoneclient/v2_0/client.py", line 172, in get_raw_token_from_identity_service
>     return a.get_auth_ref(self.session)
>   File "/usr/lib/python2.6/site-packages/keystoneclient/auth/identity/v2.py", line 84, in get_auth_ref
>     authenticated=False)
>   File "/usr/lib/python2.6/site-packages/keystoneclient/session.py", line 334, in post
>     return self.request(url, 'POST', **kwargs)
>   File "/usr/lib/python2.6/site-packages/keystoneclient/utils.py", line 324, in inner
>     return func(*args, **kwargs)
>   File "/usr/lib/python2.6/site-packages/keystoneclient/session.py", line 275, in request
>     raise exceptions.from_response(resp, method, url)
> InternalServerError: Malformed endpoint URL (see ERROR log for details):http://controller:8776/v1/%(tenant_id) (HTTP 500)
> not all arguments converted during string formatting
> root at controller1-prod.controller1-prod:/var/log/httpd#
> I found something similar on launchpad, bug 1291672 https://bugs.launchpad.net/openstack-manuals/+bug/1291672 which was closed for lack of activity.
> Thank you
> Jeff Silverman
> -- 
> Jeff Silverman
> Systems Engineer
> (253) 459-2318 (c)
> This E-mail and any of its attachments may contain Time Warner Cable proprietary information, which is privileged, confidential, or subject to copyright belonging to Time Warner Cable. This E-mail is intended solely for the use of the individual or entity to which it is addressed. If you are not the intended recipient of this E-mail, you are hereby notified that any dissemination, distribution, copying, or action taken in relation to the contents of and attachments to this E-mail is strictly prohibited and may be unlawful. If you have received this E-mail in error, please notify the sender immediately and permanently delete the original and any copy of this E-mail and any printout.
> _______________________________________________
> OpenStack-operators mailing list
> OpenStack-operators at lists.openstack.org
> http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-operators

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstack.org/pipermail/openstack-operators/attachments/20140805/162eccb0/attachment.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 536 bytes
Desc: Message signed with OpenPGP using GPGMail
URL: <http://lists.openstack.org/pipermail/openstack-operators/attachments/20140805/162eccb0/attachment.pgp>

More information about the OpenStack-operators mailing list