[Openstack-operators] Problems with openstack-nova-network-2012.2.2-1 adding floating_ips pools

Ryan Richard ryan.richard at rackspace.com
Wed Feb 27 16:29:37 UTC 2013

I was going to reply to this but you found my bug report already.

That fix does solve the which interface the floating IPs get assigned to but do the floating IPs on attached to eth0.4 work correctly? I figured there were will be routing issues on the physical host.

Ryan Richard
OpenStack Engineer
Rackspace Private Cloud
From: Miguel Angel Diaz Corchero [miguelangel.diaz at ciemat.es]
Sent: Wednesday, February 27, 2013 8:22 AM
To: openstack-operators at lists.openstack.org
Subject: Re: [Openstack-operators] Problems with openstack-nova-network-2012.2.2-1 adding floating_ips pools

On 26/02/13 16:36, Miguel Angel Diaz Corchero wrote:

We've worked with my OpenStack installation for several months and now I have to create two pools (public and private pools) of floating_ips.

I noticed that the floating_ip doesn't work correctly:

1)cat /etc/nova/nova.conf | grep public

2) I need to establish the public_interface depending on the pool, so that:
nova-manage floating create --pool=private-ips --ip_range=  --interface=eth0
nova-manage floating create --pool=prublic-ips --ip_range=  --interface=eth0.4

3) I listed my pools:
nova-manage floating list
2fd8747b4eb64ce4bd7149e2d45ff076    None    public-ips    eth0.4
2fd8747b4eb64ce4bd7149e2d45ff076    None    private-ips    eth0

4) I created the IPs from both pools
nova floating-ip-create  private-ips
nova floating-ip-create  prublic-ips

5) I add the IP to some instances ... but I can see that all the secondary IPs are created on eth0
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP qlen 1000
    link/ether 00:1a:64:5d:60:00 brd ff:ff:ff:ff:ff:ff
    inet scope global eth0
    inet scope global eth0
    inet6 fe80::21a:64ff:fe5d:6000/64 scope link
       valid_lft forever preferred_lft forever

Why all the secondary IPs are created on eth0?  It seems the public_interfaces of "nova-manage floating create" are ignored.

Any help?


Finally I solved this issue applying the modifications described in the following link:


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstack.org/pipermail/openstack-operators/attachments/20130227/7f404fb4/attachment.html>

More information about the OpenStack-operators mailing list