[Openstack-operators] Problems running large numbers of instances

Linux Datacenter linuxdatacenter at gmail.com
Fri Jan 13 08:57:43 UTC 2012


When I try to run a large number of instances in single run, like:
euca-run-instances -n <some_large_number>

where some_large_number is something like 30-50

I hit some bug which I guess is related with sqlalchemy:

in nova-api.log:
nova.api): TRACE: DetachedInstanceError: Parent instance <FixedIp at
0x6d9fdd0> is not bound to a Session; lazy load operation of attribute
'network' cannot proceed

in nova-network.log:
(nova.rpc): TRACE: TimeoutError: QueuePool limit of size 10 overflow 10
reached, connection timed out, timeout 30


Eventually, when I run euca-describe-instances, some of the instances are
stuck in "pending" state and never run.

I also tried to use cloud-run-instances,but it ends up with the same error:

Traceback (most recent call last):
  File "/usr/bin/cloud-run-instances", line 654, in <module>
  File "/usr/bin/cloud-run-instances", line 466, in main
    raise Exception('%s failed' % cmd)
Exception: euca-run-instances failed

Anyone has a remedy for this?

checkout my blog on linux clusters:
-- linuxdatacenter.blogspot.com --
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstack.org/pipermail/openstack-operators/attachments/20120113/c394169f/attachment-0002.html>

More information about the Openstack-operators mailing list