[Openstack-operators] Creating an image from a snapshot

Samuel Winchenbach swinchen at gmail.com
Thu Aug 16 02:40:22 UTC 2012

It worked fine on my second attempt (If only everything would work
after two tries!).

I am not sure what I did incorrectly the first time, but I could not
ssh to the instance with my new (testing) key.

Thanks for the help, if I run into that problem again I will try a
little harder to debug it and not just dump the instance and start


On Wed, Aug 15, 2012 at 10:02 PM, Lloyd Dewolf <lloydostack at gmail.com> wrote:
> On Wed, Aug 15, 2012 at 5:59 PM, Sam Morrison <sorrison at gmail.com> wrote:
>> Hi Sam,
>> Cloud init should run every time you start/boot/reboot up an instance from what I understand.
>> Cheers,
>> Sam
>> On 16/08/2012, at 10:41 AM, Samuel Winchenbach <swinchen at gmail.com> wrote:
>>> Hi all,
>>> I am trying to modify a stock image (http://cloud-images.ubuntu.com/)
>>> to include the software needed for our particular tasks (graphical
>>> environment, engineering software, word processor, printer, etc).  To
>>> do this I made all the changes I need to an instance and took a
>>> snapshot.  Is there a way to "reset" the image so the initial
>>> cloud-init procedures will be called for importing ssh keys (and any
>>> other setup it may do)?
> My experience is the same as Sam Morrison's.
> precise-server-cloudimg-amd64-disk1.img       15-Aug-2012 06:48  222M
> Cloud image for 64-bit computers (QCOW2 disk image file for use with
> QEMU and KVM)
> What are the symptoms you are seeing? You can manually add another key
> (hard code) to authorized_keys to help you debug the symptom.
> Cheers,
> --
> @lloyddewolf
> http://www.pistoncloud.com/
> _______________________________________________
> OpenStack-operators mailing list
> OpenStack-operators at lists.openstack.org
> http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-operators

More information about the OpenStack-operators mailing list