Volume attached to removed instance

Alan Bishop abishop at redhat.com
Wed Mar 30 22:12:06 UTC 2022

On Wed, Mar 30, 2022 at 2:42 PM Jonathan Proulx <jon at csail.mit.edu> wrote:

> On Wed, Mar 30, 2022 at 08:16:12AM +0000, Derek O keeffe wrote:
> :Hi all,
> :We are having an issue with a volume. The volume was created and attached
> to an instance that was then deleted. We now need to attach the volume to
> another instance to rescue the data on it but it still thinks it's attached
> to the deleted instance and we can't "manage attachments" or view the
> details of the volume.
> When you say
> :We have tried forcing it from the cli to detach but with no luck. We were
> thinking of doing it through the DB but said we'd askhere first in case
> anyone has experienced the same and has a better way of approaching the
> issue. Thanks in advance.
> is this what you tried?
> cinder reset-state --attach-status detached <UUID>

Assuming your cloud is based on Queens or later, these commands may also

cinder --os-volume-api-version 3.44 attachment-list
cinder --os-volume-api-version 3.44 attachment-delete <attachment ID>


> I've had the stale attachement problem a number of times and that
> one's always worked for me so here's hoping it's not what you tried...
> -Jon
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstack.org/pipermail/openstack-discuss/attachments/20220330/a00f6c7a/attachment.htm>

More information about the openstack-discuss mailing list