Devstack Installation Fails with Internal Server Error (HTTP 500)

Clark Boylan cboylan at
Fri Jun 17 16:55:54 UTC 2022

On Fri, Jun 17, 2022, at 3:16 AM, KK CHN wrote:
> I have tried the Trove Devstack installation on Ubuntu20.04  too.. But 
> no success.. 
>  ( As I have made no progress in Debian 11  Trove-Devstak installation, 
> I tried a number of times but all failed with the error ).
> To my experience..   The same error for  Ubuntu 20.04  also. 
> Followed the same  stuff : 
> The compete Error log here
> It reports an Error starting with  
> 2022-06-17 09:58:04.720 | ERROR: Cannot install trove==17.1.0.dev31 
> because these package versions have conflicting dependencies.
> 2022-06-17 09:58:04.721 | 
> 2022-06-17 09:58:04.721 | The conflict is caused by:
> 2022-06-17 09:58:04.721 |     trove 17.1.0.dev31 depends on Jinja2>=2.10
> 2022-06-17 09:58:04.721 |     The user requested (constraint) 
> jinja2===3.1.2How to overcome this  Jinja  dependency, where we need to 
> edit this and what jinja suitable ?2022-06-17 09:58:04.721 | 
> And finally   Exit with error 
> 2022-06-17 09:58:07.560 | + 
> /usr/local/lib/python3.8/dist-packages/diskimage_builder/lib/img-functions:trap_cleanup:38 
> :   exit 1
> Error on exit
> stack at kk:~/devstack$ uname -a
> Linux kk 5.11.0-27-generic #29~20.04.1-Ubuntu SMP Wed Aug 11 15:58:17 
> UTC 2021 x86_64 x86_64 x86_64 GNU/Linux
> stack at kk:~/devstack$ 

You are running devstack on Ubuntu 22.04 which installs diskimage-builder under python3.8. Then the trove devstack process attempts to build a trove database image with its agent installed. The image build run by diskimage-builder appears to be running under Ubuntu 18.04 which has python3.6 and pip 9.0.1 (this pip version is what I'm using to make this inference).

Unfortunately, the openstack master constraints no longer support python3.6. In particular jinja2 3.1.2 requires python3.7 or newer which is why you get the error above about there being a version conflict. Pip should report this more clearly (and I think very new pip may), but that is what it is trying to tell you. You have requested a specific version that cannot be installed due to a python interpreter error.

Depending on what you are trying to achieve you may be better off installing older versions of trove and openstack (using one of the stable branches of devstack). Or as an alternative you can update the trove diskimage-builder base image from Ubuntu 18.04 to 20.04 and fix whatever new problems arise from that.

More information about the openstack-discuss mailing list