simple build fails to allocate network interface at at
Thu Jun 9 11:43:39 UTC 2022

On 9 Jun 2022, at 09:58, at wrote:


I’m trying to spin up a simple OS environment in  a single vm and think that I’m making some silly mistake, but cannot spot it. Any hints would be greatly expected. I’ve tried this on a couple of laptops, with the same result, so I suspect that it’s something to do with how I’ve set up my vm, but I cannot identify it. (I think that there may be a few other devstack issues, but I’ve got to get it working to log any bugs).

I’m using a vagrant box and VirtualBox on x86 Macs (Monterey), and the devstack install/build process. Everything seems to install, but when I try:

`openstack server create --flavor 42 --image cirros-0.5.2-x86_64-disk --nic net-id=2a1a4a3a-a47b-48bd-a7df-c90fc75a1c63 --security-group default wibble`

The network id is identified from this:
[vagrant at localhost devstack]$ openstack network list
| ID                                   | Name    | Subnets                                                                    |
| 205fa7d7-7067-4f63-b3d9-6a9b37b4f11f | public  | 1bbbfa3c-8e0a-483f-a084-4e38241b3315, eecfc603-c057-4b28-90bd-950a47345410 |
| 2a1a4a3a-a47b-48bd-a7df-c90fc75a1c63 | private | e7377bed-3e22-4e8d-9c2d-ea7ba740fcfd, f915b88c-9988-4e1f-9060-a6295465699a |
| fab3fb15-cbd2-45fe-8451-3f0063d59454 | shared  | 97e6d8e6-0f57-48bc-8f1d-e30587086153                                       |

Using a public network fails with an error that this isn’t allowed.

With the private network above, the failure throws out the following errors.
[vagrant at localhost devstack]$ sudo journalctl -f |grep ERROR
Jun 08 15:33:52 localhost.localdomain nova-compute[87555]: ERROR nova.compute.manager [None req-01294678-b54a-4e40-964c-488ccf03d66c demo demo] [instance: 20e1b5bf-130a-48f9-af4e-9b4c7a475315] Instance failed to spawn: nova.exception.VirtualInterfaceCreateException: Virtual Interface creation failed
Jun 08 15:33:52 localhost.localdomain nova-compute[87555]: ERROR nova.compute.manager [instance: 20e1b5bf-130a-48f9-af4e-9b4c7a475315] Traceback (most recent call last):


The Vagrantfile (commented out lines relate to trying this with Ubunutu, which failed the same way, and attempts to use multiple vms):
# -*- mode: ruby -*-
# vi: set ft=ruby :

Vagrant.configure(2) do |config| = "eurolinux-vagrant/centos-stream-9" = "hashicorp/bionic64"

 config.hostmanager.enabled = true
 config.hostmanager.manage_host = true
 config.hostmanager.manage_guest = true
 config.hostmanager.ignore_private_ip = false
 config.hostmanager.include_offline = true

 config.ssh.pty = true

 config.vm.provision "shell", inline: $script "forwarded_port", guest: 80, host: 8080

     config.vm.provider "virtualbox" do | v |
       v.memory = "9216"
       v.cpus = "2"


I think that the vm has enough RAM, although there is minimal swap being used, but I think that this is not significant as there is much more RAM used for caching files.

Any obvious hints as to why the spin up fails to create the NIC - or somewhere to look for further and better details?


More information about the openstack-discuss mailing list