[requirements] The version of zeroconf in upper constraints no longer supports python3.6

Matthew Thode mthode at mthode.org
Fri Jan 28 13:45:53 UTC 2022

On 22-01-28 13:39:22, Sean Mooney wrote:
> On Fri, 2022-01-28 at 10:32 +0000, Mark Goddard wrote:
> > On Fri, 28 Jan 2022 at 09:30, William Szumski <will at stackhpc.com> wrote:
> > > 
> > > The zeroconf package seems to have dropped support for python3.6 since 0.38.0, see: https://github.com/jstasiak/python-zeroconf#0380. We currently have 0.38.1 in upper-constraints. My understanding was that the yoga release would still support python3.6. This is important for RHEL8 based distributions that only ship python3.6. Do we need to constrain zeroconf to a version <=0.37.0?
> > > 
> > > 
> > 
> > It should be possible to add a Python version specific requirement to
> > upper constraints.
> yes you can bascially you just list the package twice with a version sepcify
> i dont know if we still have example in master but we used to do this for py2.7 in the past
> for our devstack testing and ooo i think we do not need this but it can be done if needed for other reasons i think
> https://github.com/openstack/requirements/blob/master/upper-constraints.txt#L20-L21
> we have an example for sphinks
> rather  then <=3.8 i would just clamp it for 3.6
> > Mark
> > 

Yes, that's how it's normally done, but they haven't officially dropped
the support tag for it.  https://pypi.org/project/zeroconf/0.38.1/ still
says they support py35/36.  So that's what reqs thinks.
(uppoer-constraints.txt is a machine generated file).

Matthew Thode

More information about the openstack-discuss mailing list