[xena][nova] Libvirt Live Migration Lock

Ammad Syed syedammad83 at gmail.com
Mon Jan 24 07:21:15 UTC 2022


I have tried to troubleshoot this issue further.

- created a vm from image on local compute storage (local disk not shared
between compute nodes).
- Tried to live migrate that vm, but it failed with the same error.

I have two environments, one is on wallaby and other is on xena. The above
case works fine in wallaby but not working in xena. Is there something
related to live block migration changed in xena that is causing trouble ?


On Fri, Jan 21, 2022 at 4:02 PM Ammad Syed <syedammad83 at gmail.com> wrote:

> Hi,
> I have a weird error while performing live migration of trove instances.
> The instance has a root disk residing on a local compute node and a second
> a second disk is attached from shared storage via cinder.  There are two
> networks attached with the instance, one is vlan backed and other one is
> geneve.
> When I try to perform its live migration, it fails. I see below errors in
> libvirt logs and the same in nova-compute logs.
> Jan 19 15:56:54 host03.cloud.com libvirtd[731030]: Cannot start job
> (query, none, none) for domain instance-00000819; current job is (none,
> none, migration in) owned by (0 <null>, 0 <null>, 0
> remoteDispatchDomainMigratePrepare3Params (flags=0x9b)) for (0s, 0s, 61s)
> Jan 19 15:56:54 host03.cloud.com libvirtd[731030]: Timed out during
> operation: cannot acquire state change lock (held by
> monitor=remoteDispatchDomainMigratePrepare3Params)
> Jan 19 15:36:30 host03.cloud.com libvirtd[731030]: migration successfully
> aborted
> Any advise how to fix it ? I am using below libvirt version.
> libvirt 6.0
> qemu-kvm 4.2
> kernel 5.4
> nova 24.0
> Ammad


Syed Ammad Ali
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstack.org/pipermail/openstack-discuss/attachments/20220124/8d284713/attachment.htm>

More information about the openstack-discuss mailing list