[kolla-ansible][nova]Problem with distribution of instance on servers

Tony Liu tonyliu0592 at hotmail.com
Tue Feb 15 23:38:06 UTC 2022

Enable debug logging on nova-scheduler, you will see how the winner is picked.
I had the same issue before, caused by the build-failure weigher enabled by default.
setting build_failure_weight_multiplier to 0 resolved issue for me. Instances are
balanced by weighers (compute and memory) as expected.
shuffle_best_same_weighed_hosts and host_subset_size are not necessary, unless
it's required by certain cases.

From: Laurent Dumont <laurentfdumont at gmail.com>
Sent: February 15, 2022 12:54 PM
To: Franck VEDEL
Cc: openstack-discuss
Subject: Re: [kolla-ansible][nova]Problem with distribution of instance on servers

There are two settings we've tweaked in the past in Nova.

shuffle_best_same_weighed_hosts  --> Allow more spreading in the case of computes with the exact same specs/weights.
host_subset_size --> Helps with concurrent requests to get different hosts

Before that, we saw the same behavior with Openstack stacking VM on single computes. It still respects anti-affinity, but I don't see a good reason to not spread as a default. Changing these two was enough to allow our spread to get a little better.

On Tue, Feb 15, 2022 at 11:19 AM Franck VEDEL <franck.vedel at univ-grenoble-alpes.fr<mailto:franck.vedel at univ-grenoble-alpes.fr>> wrote:
I seem to have a problem that I hadn't seen.
I have 3 servers for my openstack, built with Kolla-ansible, I'm in Victoria version.
I had simply put the 3 servers in the [compute] part of the multinode file, at first it worked, but for some time all the VMs are placed on server 1.

The 3 servers are operational, identical. here are 3 screenshots to show it. (on the images, the instances on servers 2 and 3 are present because it worked correctly, but no more instances are created on these servers now)

I tried to understand how the instances are distributed on the servers, but in my case, I don't understand why none are assigned to the 2nd and 3rd server.
How to find the problem? It should be nova-scheduler . Do you have to do anything special? Go see if a parameter has a bad value?

Thanks in advance if you can help me.

Franck VEDEL

-------------- next part --------------
A non-text attachment was scrubbed...
Name: im1.png
Type: image/png
Size: 100474 bytes
Desc: im1.png
URL: <http://lists.openstack.org/pipermail/openstack-discuss/attachments/20220215/9936a7da/attachment-0003.png>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: Capture d?e?cran 2022-02-15 a? 16.55.13.png
Type: image/png
Size: 92774 bytes
Desc: Capture d?e?cran 2022-02-15 a? 16.55.13.png
URL: <http://lists.openstack.org/pipermail/openstack-discuss/attachments/20220215/9936a7da/attachment-0004.png>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: im3.png
Type: image/png
Size: 124170 bytes
Desc: im3.png
URL: <http://lists.openstack.org/pipermail/openstack-discuss/attachments/20220215/9936a7da/attachment-0005.png>

More information about the openstack-discuss mailing list