[TripleO] Installation of Undercloud machine on Centos 8 fails in prefetching the Images

Anirudh Gupta anyrude10 at gmail.com
Mon Sep 20 12:45:45 UTC 2021

Hi Team,

I was trying to install Undercloud on Centos 8 using the link below, but
facing error in executing "openstack undercloud install" command. The error
is in prefetch image

Steps followed:

1. Created a non root stack user

   - sudo useradd stack
   - sudo passwd stack  # specify a password
   - echo "stack ALL=(root) NOPASSWD:ALL" | sudo tee -a /etc/sudoers.d/stack
   - sudo chmod 0440 /etc/sudoers.d/stack
   - su - stack

2. Install the python-tripleo-repos

   - sudo dnf install -y
   - In order to install victoria release, executed the command -  *sudo -E
   tripleo-repos -b victoria current ceph*

3. As per the document, "*The remaining repositories configuration steps
below should not be done for stable releases!"*

   - *So, I didn't executed the command* - "sudo -E tripleo-repos
   current-tripleo-dev ceph"
   - *Is my understanding correct? This step has to be skipped in case we
   are going with a stable victoria release?*

4. Modified undercloud.conf file and executed the command

   - openstack undercloud install


2021-09-20 11:16:18,724 p=59556 u=root n=ansible | 2021-09-20
11:16:18.723422 | 525400a8-fc39-4771-208c-000000000e71 |      FATAL |
Pre-fetch all the containers | undercloud | item=
quay.io/tripleovictoria/openstack-swift-account:current-tripleo |
error={"ansible_loop_var": "prefetch_image", "changed": false, "msg":"
*Failed to pull image

5. In order to eliminate the problem, I manually installed the image -

   - sudo podman pull

After re-executing, then it again failed for the keystone image, which was
already installed on the system. I verified in *sudo podman images* command

*I tried running this 5-6 times and issue generates randomly for any
openstack image ( sometimes for rabbitmq sometimes for swift, keystone)
which is already installed in machine*

Can someone please help or suggest what step I am missing

Note: This I have tried using Centos 8 Stream and Centos 8.4(using
--no-stream), but same issue is observed in both

Anirudh Gupta
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstack.org/pipermail/openstack-discuss/attachments/20210920/308fe4d1/attachment-0001.htm>

More information about the openstack-discuss mailing list