python_requires >= 3.8 during Yoga

Ghanshyam Mann gmann at
Thu Nov 25 21:19:02 UTC 2021

 ---- On Thu, 25 Nov 2021 13:58:28 -0600 Marcin Juszkiewicz <marcin.juszkiewicz at> wrote ----
 > W dniu 25.11.2021 o 19:13, Stephen Finucane pisze:
 > > gmann has been helpfully proposing patches to change the versions of Python
 > > we're testing against in Yoga. I've suggested that we might want to bump
 > > 'python_requires' in 'setup.cfg' to indicate that we no longer support any
 > > version of Python before 3.8
 > CentOS Stream 8 has Python 3.6 by default and RDO team is doing CS8 -> 
 > CS9 migration during Yoga cycle. Can we postpone it to Z when there will 
 > be no distribution with Py 3.6 to care about?

Postponing to Z, you mean dropping the py3.6 tests or bumping it in in 'setup.cfg'
so that no one can install on py3.6 ?

First one we already did and as per Yoga testing runtime we are targeting centos9-stream[1]
in Yoga itself.

For making 'python_requires' >=py3.8 in 'setup.cfg', I have no string opinion on this but I prefer
to have flexible here that 'yes OpenStack is installable in py3.6 but we do not test it anymore
from Yoga onwards so no guarantee'.  Our testing runtime main goal is that we document the version we
are testing *at least* which means it can work on lower or higher versions too but we just do not test them.

Just for some background, we started adding  'python_requires'  in 'setup.cfg' when we dropped
py2.7 and wanted a hard stop for anyone keep using py2.7 on OpenStack. But in python3 world
we do not have to use it for every min version bump as such.




More information about the openstack-discuss mailing list