[ops] Openstack Victoria SPICE configuration not working

number9 number9 at dimlight.org
Thu Aug 5 17:25:15 UTC 2021

I have posted this on stackexchange, but am also asking here:

Running openstack on Ubuntu 20.04 with a controller node and four 
compute nodes. I am reading the instructions on configuring SPICE here. 
I will admit, I found out about which packages to install from other 
sites, as the instructions at the link do not actually list any software 
that needs to be installed.

     On the compute nodes and controller, I installed nova-spiceproxy
     On the controller I installed nova-spiceproxy and spice-html5

I followed the instructions in the link on configuring 
/etc/nova/nova.conf on the controller and all compute nodes.

In a nutshell, when you click on console in the dashboard, it simply 

Something went wrong!

An unexpected error has occurred. Try refreshing the page. If that 
doesn't help, contact your local administrator.

I have parsed every log in /var/log on the compute and controller nodes 
and found nothing that would indicate it is failing.

On the compute node, I can do a ps aux and see that spice is running on 
the instance I am trying to connect to.

I am really not sure where to go. I have tried VNC and noVNC also to no 
avail, each time completely removing the old
configs and only adding the new. I have reverted back to SPICE to try 
the "simple" approach.

My relevant config items in /etc/nova/nova.conf from a compute node are:

vnc_eanabled = false
# yes, I know it is redundant, I am following the docs...

enabled = false

enabled = true
agent_enabled = true
html5proxy_base_url =
# the above IP is the IP of the controller.
server_listen =
server_proxyclient_address =
# the above IP is the IP of the controller that I pulled this config 
html5proxy_host =
html5proxy_port = 6082

Back on the controller node, in /etc/nova/nova.conf I have:

enabled = true
agent_enabled = false
html5proxy_host =
html5proxy_port = 6082
keymap = en_us

I also have vnc false, as it is on the compute nodes. I will admit 
further, I have tried at least 20 iterations of this, just leaving off 
proxy ports, or thinking for a moment that the proxyclientaddress was 
the controller node, but none of them work. I do restart nova on the 
controller and all compute nodes after every change.

Any ideas or directions would be appreciated. I wish there were logs, I 
am perhaps missing them or need to turn on debugging of some kind.

More information about the openstack-discuss mailing list