[i18n] Zanata

Clark Boylan cboylan at sapwetik.org
Thu Aug 5 15:03:29 UTC 2021

On Wed, Aug 4, 2021, at 8:35 PM, 韩光宇 wrote:
> Hi,
> Thank you very very much for you, you work so hard to help me out. 
>  You can delete directly the existing account and don't need to check 
> with me again. I just hope the email can log in it.

I have deleted the existing user account via the web ui admin manage users page.

> About how this happen, I think your guess is right. The first, I signed 
> up in https://translate.openstack.org/. But when I log in, it need 
> OpenID. So, the second step, I sign up openid. And then, I can't log in 
> as now. I'm sorry if my operation is incorrect.
> Thank you,
> Han Guangyu
> ------------------ Original ------------------
> *From: * "Clark Boylan"<cboylan at sapwetik.org>;
> *Date: * Thu, Aug 5, 2021 06:49 AM
> *To: * "Jimmy McArthur"<jimmy at openstack.org>; 
> "openstack-discuss at lists.openstack.org"<openstack-discuss at lists.openstack.org>; 
> *Cc: * "hanguangyu at uniontech.com"<hanguangyu at uniontech.com>; 
> *Subject: * Re: [i18n] Zanata
> On Wed, Aug 4, 2021, at 3:07 PM, Jimmy McArthur wrote:
> > Apologies for the delayed response here, but the user I'm trying to 
> > help is indeed unable to log in to Zanata.  We've set up a temporary 
> > password for them and I've tried myself and it's basically a loop.  It 
> > says there is already an account with that name, but it won't let him 
> > log in, it keeps pointing him to the screen to create a new account.
> > 
> > Here's a link to a video demonstrating the problem.  I've tried myself 
> > with their credentials and get the same: 
> > https://drive.google.com/file/d/1iE0iWoYgTb5zk3SzP8oB5aYrtplRqlEm/view?usp=sharing
> > CC'ing Han Guangyu, the user with the issue.
> > 
> > Any help appreciated!  Their company is looking to start contributing 
> > to i18n team, so it would be great if we could get them going :)
> Sorry, I missed this thread initially as it was was sent to the [i18n] 
> label. The OpenDev/OpenStack infra team run the Zanata server, in the 
> future sending email to service-discuss at lists.opendev.org is more 
> likely to get eyeballs on this sort of thing. It also helps if people 
> having problems reach out directly so that we don't resort to playing 
> telephone and missing important information.
> Looking at the attached video, the error is that a user with the 
> specified email address already exists. Looking at the database I see 
> that there are records for this email address in the HAccount and 
> HPerson tables but no openstackid openid is associated with this 
> account in the HCredentials table.
> On closer inspection of the records that are present I note there is a 
> password hash set, but there shouldn't be any password hashes if 
> openstackid openid is used to login and create the account. I think 
> what happened is somehow an account was created directly and not via 
> openid. Now when attempting to login with openid there is a conflict 
> because an account already has that email address. It would be good to 
> understand how this happened if possible so that we can avoid it for 
> the future.
> As far as fixing this account goes I suspect that if we delete the 
> existing account then the next login attempt will be able to 
> successfully create a new account with the associated openid. I don't 
> know that we've ever done this before so coordinating this deletion 
> when login can be reattempted is a good idea.
> Finally, it is worth noting that the translation tooling needs help, 
> not just the translations themselves. Unfortunately the software we are 
> using for this is no longer maintained and ideally needs to be replaced.

More information about the openstack-discuss mailing list