[all] OpenStack versions that can't practically be run with Python 3 ?

Ghanshyam Mann gmann at ghanshyammann.com
Tue Jun 2 17:36:04 UTC 2020

 ---- On Tue, 02 Jun 2020 09:02:18 -0500 David Ivey <david.j.ivey at gmail.com> wrote ----
 > For me, Stein still had a lot of issues with python3 when I tried to use it, but I had tried the upgrade shortly after Stein had released so those issues may have been resolved by now. I ended up reverting back to Rocky and python2.7,  My first real stable build with python3 was with the Train release on Ubuntu18.04, so I skipped the Stein release. 

We did migrate the upstream integration testing to Ubuntu 18.04 in Stein [1], so
I feel stein should be fine on python3 until we are missing the scenario failing for you in our testing.

 > Someone can correct me if I am wrong, but last I checked, CentOS 7 did not have the python3 packages in RDO. So if using CentOS 7; RDO does not have Ussuri and the latest release there is Train with python2.7. If using CentOS 8 and the Ussuri release; RDO released the python3 packages last week. 
 >  I have not tried Ussuri on CentOS 8 yet.
 > David
 > On Tue, Jun 2, 2020 at 8:25 AM Sean McGinnis <sean.mcginnis at gmx.com> wrote:
 > On 6/2/20 6:34 AM, Neil Jerram wrote:
 > > Does anyone know the most recent OpenStack version that
 > > _can't_ easily be run with Python 3?  I think the full answer to this
 > > may have to consider distro packaging, as well as the underlying code
 > > support.
 > >
 > > For example, I was just looking at switching an existing Queens setup,
 > > on Ubuntu Bionic, and it can't practically be done because all of the
 > > scripts - e.g. /usr/bin/nova-compute - have a hashbang line that says
 > > "python2".
 > >
 > > So IIUC Queens is a no for Python 3, at least in the Ubuntu packaging.
 > >
 > > Do you know if this is equally true for later versions than Queens? 
 > > Or alternatively, if something systematic was done to address this
 > > problem in later releases?  E.g. is there a global USE_PYTHON3 switch
 > > somewhere, or was the packaging for later releases changed to hardcode
 > > "python3" instead of "python2"?  If so, when did that happen?

USE_PYTHON3 in devstack was switched to True by default in Ussuri cycle, but we moved
(unit test as well as integration tests) on python3 by default:

- Unit tests (same as Sean already mentioned)- https://governance.openstack.org/tc/goals/selected/stein/python3-first.html
- [1] Integration testing: http://lists.openstack.org/pipermail/openstack-discuss/2019-April/004647.html

If something is failing with Stein on python 3 then I will suggest reporting the bug and we can check if that can be fixed.


 > >
 > Stein was the release where we had a cycle goal to get everyone using
 > Python 3:
 > https://governance.openstack.org/tc/goals/selected/stein/python3-first.html
 > Part of the completion criteria for that goal was that all projects
 > should, at a minimum, be running py3.6 unit tests. So a couple of
 > caveats there - unit tests don't always identify issues that you can run
 > in to actually running full functionality, and not every project was
 > able to complete the cycle goal completely. Most did though.
 > So I think Stein likely should work for you, but of course Train or
 > Ussuri will have had more time to identify any missed issues and the like.
 > I hope this helps.
 > Sean

More information about the openstack-discuss mailing list