[all] OpenStack versions that can't practically be run with Python 3 ?

Alfredo Moralejo Alonso amoralej at redhat.com
Tue Jun 2 14:21:03 UTC 2020

On Tue, Jun 2, 2020 at 4:06 PM David Ivey <david.j.ivey at gmail.com> wrote:

> For me, Stein still had a lot of issues with python3 when I tried to use
> it, but I had tried the upgrade shortly after Stein had released so those
> issues may have been resolved by now. I ended up reverting back to Rocky
> and python2.7, My first real stable build with python3 was with the Train
> release on Ubuntu18.04, so I skipped the Stein release.
> Someone can correct me if I am wrong, but last I checked, CentOS 7 did not
> have the python3 packages in RDO. So if using CentOS 7; RDO does not have
> Ussuri and the latest release there is Train with python2.7. If using
> CentOS 8 and the Ussuri release; RDO released the python3 packages last
> week.
CentOS 7 has some limited python3 support but at  RDO we didn't do any
release with python3 on CentOS 7.

In RDO you have python3 packages for CentOS 8 for both Train and Ussuri.

>  I have not tried Ussuri on CentOS 8 yet.
> David
> On Tue, Jun 2, 2020 at 8:25 AM Sean McGinnis <sean.mcginnis at gmx.com>
> wrote:
>> On 6/2/20 6:34 AM, Neil Jerram wrote:
>> > Does anyone know the most recent OpenStack version that
>> > _can't_ easily be run with Python 3?  I think the full answer to this
>> > may have to consider distro packaging, as well as the underlying code
>> > support.
>> >
>> > For example, I was just looking at switching an existing Queens setup,
>> > on Ubuntu Bionic, and it can't practically be done because all of the
>> > scripts - e.g. /usr/bin/nova-compute - have a hashbang line that says
>> > "python2".
>> >
>> > So IIUC Queens is a no for Python 3, at least in the Ubuntu packaging.
>> >
>> > Do you know if this is equally true for later versions than Queens?
>> > Or alternatively, if something systematic was done to address this
>> > problem in later releases?  E.g. is there a global USE_PYTHON3 switch
>> > somewhere, or was the packaging for later releases changed to hardcode
>> > "python3" instead of "python2"?  If so, when did that happen?
>> >
>> Stein was the release where we had a cycle goal to get everyone using
>> Python 3:
>> https://governance.openstack.org/tc/goals/selected/stein/python3-first.html
>> Part of the completion criteria for that goal was that all projects
>> should, at a minimum, be running py3.6 unit tests. So a couple of
>> caveats there - unit tests don't always identify issues that you can run
>> in to actually running full functionality, and not every project was
>> able to complete the cycle goal completely. Most did though.
>> So I think Stein likely should work for you, but of course Train or
>> Ussuri will have had more time to identify any missed issues and the like.
>> I hope this helps.
>> Sean
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstack.org/pipermail/openstack-discuss/attachments/20200602/b0934ca5/attachment-0001.html>

More information about the openstack-discuss mailing list