Galera and haproxy fail; keystone error 'Lost connection to MySQL server during query'

Albert Braden Albert.Braden at
Fri Feb 7 19:15:58 UTC 2020

If I run galera without haproxy and point everything to 1 server, it seems to work fine, but we want to load-balance it with haproxy. After setting up haproxy we had lots of errors in nova, neutron and keystone, but I got rid of those by setting haproxy timeout values to 10 minutes. The remaining errors are in keystone. In /var/log/keystone/keystone-wsgi-public.log I see "Loaded 2 Fernet keys" every 5 minutes and this is frequently accompanied by a mysql error 'Lost connection to MySQL server during query'

I tried changing various config items in haproxy, galera and keystone, but nothing seems to help. How can I fix these errors?


Haproxy config:

Mysql timeout values:

Keystone config (minus commented lines):
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the openstack-discuss mailing list