[neutron] port binding issues after upgrade attempt

Jean-Philippe Méthot jp.methot at planethoster.info
Thu Apr 16 01:06:13 UTC 2020


We’ve been running a somewhat old version of openstack-queens for a while (I don’t know the exact release number, you will understand why shortly). Our setup has dedicated network nodes which we set up to use l3ha not too long ago. The package version was more recent on the second network node than on the first one because of that, however, high availability worked fine. We then tried to upgrade to rocky and since then, we get binding failed errors for pretty much all our ports whenever a router change network node.

The only way we’ve found to fix this is to shutdown our neutron services and then reimport our pre-upgrade openstack database backup. This way, every port gets created properly, as it was at the time.

Since then we have:

-Moved everything back to queens.
-Reinstalled our controller and network nodes from scratch (which is why I don’t know which queens version we were using before).

However, this issue still happens as soon as the router change network node. Most ports get binding failed errors and restoring the database backup is the only way we managed to get out of this issue each time. We use neutron-openvswitch for networking and tunneling is done with GRE. Our OS is centos 7.

Is it possible that code pertaining to HA may have changed in the later versions of queens and rocky which could explain that we’re running into a bug of some sort? Is there a way I could get neutron to tell me exactly why port binding is failing?

Jean-Philippe Méthot
Senior Openstack system administrator
Administrateur système Openstack sénior
PlanetHoster inc.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstack.org/pipermail/openstack-discuss/attachments/20200415/ca4c369e/attachment-0001.html>

More information about the openstack-discuss mailing list