Freezer Project Update

Deepa at
Wed Nov 20 12:35:31 UTC 2019

Hello Amjad/James


We tried installing Freezer .Freezer-scheduler and Freezer-agent in a VM which need to be backed up and Freezer-api and freezer-webui on controller node.The version of Openstack is Train.


Unfortunately nothing worked out ☹


Getting below error on VM (client to be backed up) when I run freezer-agent --action info


Critical Error: Authorization Failure. Authorization Failed: Not Found (HTTP 404) (Request-ID: req-0c71d8b4-ef1a-4c8d-8d12-26df763f5085)


And getting error in Dashboard when we enabled Freezer-api and freezer-webui in dashboard


During handling of the above exception ([*] Error 401: {"error": {"message": "The request you have made requires authentication.", "code": 401, "title": "Unauthorized"}}), another exception occurred:


Doubt the issue is with keystone versioning v2/v3.It will be great if you can share or tell freeze.env file for Freezer-agent (For client VM) and freezer-api.conf file parameters.

Also what should be admin.rc file for freezer-webui.


freezer-scheduler --config-file /etc/freezer/scheduler.conf start

Could not find versioned identity endpoints when attempting to authenticate. Please check that your auth_url is correct. Not Found (HTTP 404) (Request-ID: req-2adb597d-7ad5-45a8-9888-6b552c8e55cc)


Any guidance is highly appreciated .


Thanks a lot 



Deepa K R


From: James Page < at> 
Sent: Tuesday, November 19, 2019 10:19 PM
To: Amjad Kotobi <kotobi at>
Cc: Deepa < at>; OpenStack Development Mailing List (not for usage questions) <openstack-dev at>
Subject: Re: Freezer Project Update




On Fri, Nov 15, 2019 at 7:43 PM Amjad Kotobi <kotobi at <mailto:kotobi at> > wrote:



This project is pretty much in production state, from last summit it got active again from developer ends, we are using it for backup solution too.


Great to hear that Freezer is getting some increased developer focus!


Documentation side isn’t that bright, very soon gonna get updated, anyhow you are able to install as standalone project in instance, I did it manually, didn’t use any provision tools.

Let me know for specific part of deployment that is not clear.



On 14. Nov 2019, at 06:53, Deepa < at < at> > wrote:


Hello Team 


  Good Day 


I am Deepa from Fingent Global Solutions and we are a big fan of Openstack and we do have 4 + openstack setup (including production)

We have deployed Openstack using juju and Maas .So when we check for backup feasibility other than cinder-backup we were able to see

Freezer Project. But couldn’t find any charms for it in juju charms. Also there isn’t a clear documentation on how to install freezer .

 <> No proper release notes in the latest version as well.

Can you please tell me whether this project is in developing state? Whether charms will be added to juju in future.


Freezer is not currently on the plan for OpenStack Charms for Ussuri.  Better install documentation and support from Linux distros would be a good first step in the right direction.





-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the openstack-discuss mailing list