[ops] [nova] How to change/remove a property from an instance ?

Matt Riedemann mriedemos at gmail.com
Wed Jul 24 15:45:02 UTC 2019

On 7/24/2019 10:19 AM, Massimo Sgaravatto wrote:
> I first tried to change the value of that property (qemu --> kvm) [*]
> I also tried to remove the property [**] but the nova migrate keeps 
> failing. In the request I keep seeing that
> Instance contains properties ImageMetaProps...img_hv_type='qemu'
> What else needs to be modified?

The filter is working on the ImageMetaProps object hydrated from the 
json serialized string in the request_specs.spec column, which 
unfortunately makes fixing this a bigger pain in the ass since it's not 
a simple SQL update statement.

If I were you I'd probably just revert 
https://review.opendev.org/#/c/531347/ so you can get on with your Rocky 
upgrade while we deal with fixing the issue long-term upstream, either 
by reverting that change upstream as well or adding a compat shim in the 




More information about the openstack-discuss mailing list