[stein][cinder][backup][swift] issue

Ignazio Cassano ignaziocassano at gmail.com
Mon Dec 30 14:48:29 UTC 2019

Hello All,
I configured openstack stein on centos 7 witch ceph.
Cinder works fine and object storage on ceph seems to work fine: I can
clreate containers, volume etc .....

I configured cinder backup on swift (but swift is using ceph rados gateway)

backup_driver = cinder.backup.drivers.swift.SwiftBackupDriver
swift_catalog_info = object-store:swift:publicURL
backup_swift_enable_progress_timer = True
#backup_swift_url =
backup_swift_auth_url =
backup_swift_auth = per_user
backup_swift_auth_version = 1
backup_swift_user = admin
backup_swift_user_domain = default
#backup_swift_key = <None>
#backup_swift_container = volumebackups
backup_swift_object_size = 52428800
#backup_swift_project = <None>
#backup_swift_project_domain = <None>
backup_swift_retry_attempts = 3
backup_swift_retry_backoff = 2
backup_compression_algorithm = zlib

If I run a backup as user admin, it creates a container named
If I run a backup as user demo and I do not specify a container name, it
tires to write on volumebackups and gives some errors:

ClientException: Container PUT failed:
409 Conflict   BucketAlreadyExists

Does it mean I cannot use the same containers name on differents projects ?

My ceph.conf is configured for using keystone:
rgw_frontends = "civetweb port="
# Keystone information
rgw keystone api version = 3
rgw keystone url =
rgw keystone admin user = admin
rgw keystone admin password = password
rgw keystone admin domain = default
rgw keystone admin project = admin
rgw swift account in url = true
rgw keystone implicit tenants = true

Any help, please ?
Best Regards
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstack.org/pipermail/openstack-discuss/attachments/20191230/04e419fc/attachment.html>

More information about the openstack-discuss mailing list