[openstack-dev] [Release-job-failures][neutron] Release of openstack/networking-bigswitch failed

AdityaVaja wolverine.av at gmail.com
Wed Oct 3 14:31:19 UTC 2018

Hello Doug,

I was going to send out an email or drop in on IRC to check how to fix that.

We accidentally pushed 13.0.1 on stable/queens, instead of 12.0.5. (13.x.x
is rocky and 12.x.x is queens)
Tried reverting the situation by pushing 12.0.5 for the same commit hash on
queens, but that didn't work. Releases with commit hash can be compared
here [1].

Deleting the release from PYPI can be done, but deleting a tag from gerrit
is not possible without allowing forcePush from project-config - afaik. But
that seems like an extreme step.
Not sure how to fix the situation, so I thought checking with
openstack-release to get an idea.

If your original suggestion of pushing 12.0.6 still stands, I can go ahead
and do that.


[1] https://github.com/openstack/networking-bigswitch/releases

On Wed, Oct 3, 2018 at 9:47 PM Doug Hellmann <doug at doughellmann.com> wrote:

> zuul at openstack.org writes:
> > Build failed.
> >
> > - release-openstack-python
> http://logs.openstack.org/d1/d1df2f75e0e8259ddaaf5136f421567733ba7f5b/release/release-openstack-python/8a89663/
> : FAILURE in 6m 19s
> > - announce-release announce-release : SKIPPED
> > - propose-update-constraints propose-update-constraints : SKIPPED
> It looks like there's something wrong with the versioning in the
> stable/queens branch of the networking-bigswitch repository.
> The error I see when I run "python setup.py --name" locally is:
>   ValueError: git history requires a target version of
>   pbr.version.SemanticVersion(13.0.1), but target version is
>   pbr.version.SemanticVersion(12.0.5)
> This is being caused by re-tagging the 13.0.1 release as 12.0.5.
> I think if we tag a *newer* commit as 12.0.6 that will work (it seems to
> work locally).
> Doug
> __________________________________________________________________________
> OpenStack Development Mailing List (not for usage questions)
> Unsubscribe: OpenStack-dev-request at lists.openstack.org?subject:unsubscribe
> http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev

via telegram
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstack.org/pipermail/openstack-dev/attachments/20181003/68be36fd/attachment.html>

More information about the OpenStack-dev mailing list