[openstack-dev] [all][api] POST /api-wg/news
ed at leafe.com
Thu Jun 8 21:15:15 UTC 2017
On Jun 8, 2017, at 11:59 AM, Chris Dent <cdent+os at anticdent.org> wrote:
> The naming issue related to an optional field we want to add to the microversion discovery document. Some projects wish to be able to signal that they are intending to raise the minimum microversion at a point in the future. The name for the next minimum version is fairly clear: "next_min_version". What's less clear is the name which can be used for the field that states the earliest date at which this will happen. This cannot be a definitive date because different deployments will release the new code at different times. We can only say "it will be no earlier than this time".
> Naming this field has proven difficult. The original was "not_before", but that has no association with "min_version" so is potentially confusing. However, people who know how to parse the doc will know what it means so it may not matter. As always, naming is hard, so we seek input from the community to help us find a suitable name. This is something we don't want to ever have to change, so it needs to be correct from the start. Candidates include:
> * not_before
> * not_raise_min_before
> * min_raise_not_before
> * earliest_min_raise_date
> * min_version_eol_date
> * next_min_version_effective_date
> If you have an opinion on any of these, or a better suggestion please let us know, either on the review at <https://review.openstack.org/#/c/446138/ <https://review.openstack.org/#/c/446138/>>, or in response to this message.
Even better: please respond on the SurveyMonkey page to rank your preferences!
-- Ed Leafe
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the OpenStack-dev