[openstack-dev] [kloudbuster] authorization failed problem

Alec Hothan (ahothan) ahothan at cisco.com
Mon Mar 28 15:29:19 UTC 2016

Can you describe what you mean by "do not have a cinder service"?
Can you provide the output of "keystone service-list"?

We'd have to know a bit more about what you have been doing:
how did you install your openstack, how did you install kloudbuster, which kloudbuster qcow2 image version did you use, who did you run kloudbuster (cli or REST or web UI), what config file have you been using, complete log of the run (including backtrace)...

But the key is - you should really have a fully working openstack deployment before using kloudbuster. Nobody has never tried so far to use kloudbuster without such basic service as cinder working.



From: Akshay Kumar Sanghai <akshaykumarsanghai at gmail.com<mailto:akshaykumarsanghai at gmail.com>>
Date: Monday, March 28, 2016 at 6:51 AM
To: OpenStack List <openstack-dev at lists.openstack.org<mailto:openstack-dev at lists.openstack.org>>, Alec Hothan <ahothan at cisco.com<mailto:ahothan at cisco.com>>
Cc: "Yichen Wang (yicwang)" <yicwang at cisco.com<mailto:yicwang at cisco.com>>
Subject: Re: [openstack-dev] [kloudbuster] authorization failed problem

Hi Alec,
Thanks for the help. I ran into another problem. At present I do not have a cinder service. So ,when i am trying to run kloudbuster, I am getting this error:
"EndpointNotFound: publicURL endpoint for volumev2 service not found"
Is it possible to run the scale test (creation of VMs, router, network) without having a cinder service? Any option that can be used so that kloudbuster can run without cinder.


On Wed, Mar 23, 2016 at 9:05 PM, Alec Hothan (ahothan) <ahothan at cisco.com<mailto:ahothan at cisco.com>> wrote:
Hi Akshay

The URL you are using is a private address ( and is likely the reason it does not work.
If you run the kloudbuster App in the cloud, this app needs to have access to the cloud under test.
So even if you can access from your local browser (which runs on your workstation or laptop) it may not be accessible from a VM that runs in your cloud.
For that to work you need to get an URL that is reachable from the VM.

In some cases where the cloud under test is local, it is easier to just run kloudbuster locally as well (from the same place where you can ping
You can either use a local VM to run the kloudbuster image (vagrant, virtual box...) or just simpler, install kloudbuster locally using git clone or pip install (see the installation instructions in the doc http://kloudbuster.readthedocs.org/en/latest/).



-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstack.org/pipermail/openstack-dev/attachments/20160328/8a2d5487/attachment.html>

More information about the OpenStack-dev mailing list